This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] wget and Zope crashes on post-2.0.6 -testing

On Thu, 2 Jun 2005, Ian Pratt wrote:

Funny you should say that....

Please don't all download it at once, but there's a preview avilable at:

Wow! Thanks... I'll look into that.

If you're running NTP in your local domain you should enable

e.g. echo 1 > /proc/sys/xen/independent_wallclock or put
independent_wallclock=1 on your kernel command line. [NB: someone should
document the kernel config option]

I'll wager that this is your problem. Hmm, that's a pretty nasty failure
mode. Without doing something gross and intercepting the adjtimex
syscall there's not a lot we can do about it.

I'm not running NTP in domU, but it should be running in dom0, although it seems it's not working since the clock is out of sync.

I turned on independent_wallclock and was just about to report that it fixed the problem, and then it happened again. Twice. That is, SETI broke wget, even with independent_wallclock=1.

Also, with "apt-get install ntpdate ntp-simple" and SETI running I get this interesting Perl error (which I've seen before, during high load):

debconf: Perl may be unconfigured (Global symbol "%priorities" requires explicit package name at /usr/share/perl5/Debconf/Priority.pm line 16. Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 7. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 8.
Compilation failed in require at (eval 1) line 4.
BEGIN failed--compilation aborted at (eval 1) line 4.
) -- aborting

And wget occasionally dies with "malloc: not enough memory", when the machine has 1 gig of free RAM (total 1,5G) plus 3G of swap. This is getting really weird...

I installed ntp on the domU in question and the problem remains, with independent_wallclock=1, ntp running and the clock in sync with the world.


*** Osma Suominen / MB Concert Ky *** osma.suominen@xxxxxxxxxxxx ***

Xen-devel mailing list