This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] wget and Zope crashes on post-2.0.6 -testing

On Thu, 2 Jun 2005, Ian Pratt wrote:

I can't reproduce this wget crash, even running seti@home in the
background as you suggest.
I'm running this in dom0 on an SMP Xeon box.

Are you running NTP on your system? If so, what does "echo peers | ntpq"
show? What happens if you disable it?

Is there anything odd about the system? Is the CPU clock speed correctly

Unfortunately the machine is not completely in my control. It is owned by another company and I only have access to dom1 and dom2, not dom0 (no other domains on the machine). But I will try to reproduce this on another machine. It might be a lot easier if there was a 2.0.6 demo CD, though...

It was easy to cause this crash with the 2.0.5 demo CD. I succeeded on all 3 machines (most of them old) I tried it on. The recipe was in a previous post to the list. But maybe Xen has changed so much that it's not relevant anymore.

Anyway, the machine I'm now observing is a Pentium IV server with HyperThreading. ntpd is running in dom0. As far as I can tell the clock speed (3.0GHz) is correctly reported. There are two identical machines, and the problem occurs on both (and in both dom1 and dom2), so broken hardware is likely not to blame.

AFAICT there is nothing odd with these machines; in fact the company owning them seems to make a good business out of renting out Xen domains to customers like me. However, since others aren't complaining loudly, the problem could be something related to the specific workload I'm putting on the machines.

You could try the unstable tree -- it would certainly be interesting to
know if there was a difference. The issue must be really quite specific
to your machine or setup (e.g. the crystal is completely knackered) as
otherwise lots of people would be complaining.

As I said the specific machine is not entirely in my control but I have the feeling I might be able to reproduce this on a spare machine, since it was so easy with 2.0.5. In that case I will try unstable as well.

Anyway, thanks for your input. I will look at whether NTP is involved and do some further investigation.


*** Osma Suominen / MB Concert Ky *** osma.suominen@xxxxxxxxxxxx ***

Xen-devel mailing list