[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] need known working 64-bit upstream kernel config file for PV guest

On Fri, May 14, 2010 at 09:58:47AM -0700, Dan Magenheimer wrote:
> > But I hadn't noticed the problem in the earlier part of
> > the boot before you pointed it out.
> > I'm beginning to suspect that there is a bug in 64-bit
> > upstream kernels that is exposed in nash (the lightweight
> > shell that gets bundled in a RedHat initrd).  If so,
> > it will be very difficult to track down, though clearly
> > it is fixed in one of the many Fedora kernel patches.
> > So I am going to give up on 64-bit upstream kernels
> > for now so I can get some other things done and
> > come back to this later.
> To add one more very interesting piece of data,
> booting a 2.6.32 32-bit kernel.org kernel in a PV
> guest works, while booting a 32-bit
> kernel.org kernel doesn't... same config file!
> And the failure looks very similar to the one
> I've been seeing on several x86_64 kernel.org
> kernels.
> I'll confirm that I can reproduce this, and then
> post as a separate thread.

I tried both 32bit and 64bit Linux upstream 
kernel.org kernels, and they worked ok for me. 

That was actually save/restore testing, which also worked OK,
for both uni-vcpu and multi-vcpu guests.

Dom0 was EL5.

-- Pasi

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.