[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: [Xen-users] xen/stable-2.6.32.x compilation failure in do_hvm_suspend()

  • To: Pierre POMES <pierre.pomes@xxxxxxxxxxxxxxxxxx>
  • From: chris <tknchris@xxxxxxxxx>
  • Date: Fri, 14 May 2010 13:41:34 -0400
  • Cc: Xen-Devel List <xen-devel@xxxxxxxxxxxxxxxxxxx>, Xen-Users List <xen-users@xxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Fri, 14 May 2010 10:44:22 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=Cg9A2VzLv/Q3A0vu+McO8eZPwFJ2fMI+TivH1/Ns3DneL0H2jE1CkR3Rzj91kEg7/V Tbse/ZulwYnexHu8SzL4ERZ/8/TUHlwVLE1nfDuAn2EbpyikUW6r3lqVsGzksvIkex1l e9PEiqwKs+UcXBZZTkt5mM9OYqzkppM83VUoU=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

I haven't figured out what is different yet, but I CAN build with this kernel config. So what's different in pasi's config that causes it to fail?

Thanks Pierre!

- chris

On Fri, May 14, 2010 at 1:32 PM, Pierre POMES <pierre.pomes@xxxxxxxxxxxxxxxxxx> wrote:
Hi Chris,

I just build yesterday a pvops kernel with the config in attachment, on Ubuntu lucid 64 bits, from "xen/stable-2.6.32x" git branch. In my case, the tree does not seem broken.

My version of gcc is :

root@narbonne:/usr/src/XEN/debian/xen-3.4-3.4.1# gcc -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.3-4ubuntu5' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-plugin --enable-objc-gc --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)

Maybe a problem with your gcc ? I trashed all mail, can you remind me the error you have ? I don't know if I could help you, but I will have a look.


Is there any update on this? I would imagine the broken tree is kind
of a big deal since many people build their dom0 from this? Even a
workaround would be nice for the time being...

On Thu, May 13, 2010 at 2:50 PM, chris <tknchris@xxxxxxxxx> wrote:
i tried setting


On Thu, May 13, 2010 at 2:44 PM, M A Young <m.a.young@xxxxxxxxxxxx> wrote:
On Thu, 13 May 2010, chris wrote:

I tried your config options and they do not help at all. Just FYI for
other people following this thread
What option did you change?

       Michael Young

Xen-devel mailing list

Pierre Pomès
Responsable Administration Système - System Administration Manager
ReservIT http://www.reservit.com
Direct:  +33 (0)4 86 06 51 82
Standard:  +33 (0)4 86 06 50 50
Fax:  +33 (0)4 86 06 50 51
Actiparc 1, Bâtiment 1.5
9001 Avenue Claude Antonetti
13821 La Penne sur Huveaune - France

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.