[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] New kernel won't boot

On Mon, Nov 03, 2003 at 10:30:06PM +0000, Keir Fraser wrote:
> > This error happens before I can give the boot 
> > command (I'm using the grub shell, launched via MBR,
> > after rebooting my system).  Basically:
> > 
> > grub> root (hd0,0)
> > grub> kernel /xenimage.gz   [args...doesn't matter which]
> > Error 13: Invalid or unsupported executable format
> So it's the new build of Xen that doesn't work?

I tried it with the 1.0 build from the CD image,
and from last Thursday's "unstable" download via BitKeeper.
Both yielded essentially the same results.

> It looks like it's not recognising the Xen image as a Multiboot OS. 

Correct.  The Linux "file" command thinks it's data.
But "file vmlinux" doesn't recognize it as a Linux kernel,
while "file /boot/vmlinuz" (my current non-Xen kernel) does.

So, the problem might be happening before the Multiboot
bytes are added (in arch/xeno/boot during "make bzImage").

> What happens if you try using the non-gzipped image (you can take
> xenimage.gz and just gunzip it, and try that)?

No difference...same problem.

> If it still fails then we might be able to take a look at it if you
> can make your image available to us (maybe put it on a web server and
> send us a URL?). I think someone else reported a similar problem a
> while ago. Perhaps our build process is broken for certain versions of
> gcc and/or binutils. Unfortunately it's not possible to get more
> useful diagnostics out of GRUB without adding tracing to the source
> code and recompiling it.

I put the whole package, new & old & copies of everything
in /boot at:

One of the (many) images I've tried is:

In the boot/grub/menu.lst , you'll see the approximate
grub commands (I have been typing them in by hand at the
grub> prompt, as mentioned earlier).  But the exact
sequence doesn't matter: grub complains about 
/xenimage.gz and won't proceed with a boot.

The image from the CD is just fine.  But *both* the multi-boot
images (from xen/arch/boot) and "default" vmlinux (from
the root kernel compile directory) fail with the same
"error 13" from Grub.  From *both* the 1.0 and nightly
unstable builds.

If it would help, I can set you up with access to
the machine to try some different configuration tricks.
If you think an earlier compiler would help, I can try it.
I'm at version 2.14 for my binutils, BTW, and 3.3 for gcc.

Thanks!  Greg

This SF.net email is sponsored by: SF.net Giveback Program.
Does SourceForge.net help you be more productive?  Does it
help you create better code?   SHARE THE LOVE, and help us help
YOU!  Click Here: http://sourceforge.net/donate/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.