[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] New kernel won't boot

  • To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
  • From: "Gregory Newby" <newby@xxxxxxxx>
  • Date: Mon, 3 Nov 2003 12:57:42 -0900
  • Delivery-date: Mon, 03 Nov 2003 21:58:26 +0000
  • List-id: List for Xen developers <xen-devel.lists.sourceforge.net>

The Xen 1.0 CD works fine, and I can start booting the
image.gz and xenolinux.gz via Grub if I copy them to
my hard drive.

However, I need to build a new kernel in order to
support the rest of my hardware, also my ReiserFS 
filesystems (I strongly advise adding ReiserFS to
the default for the next Xen release, since it is
there by default on SuSE).

I have tried oodles of variations, which I'll
list below.  The bottom line, though, seems to
be that I'm ending up with an invalid kernel that
Grub refuses to boot:

        Error 13: Invalid or unsupported executable format

This error happens before I can give the boot 
command (I'm using the grub shell, launched via MBR,
after rebooting my system).  Basically:

grub> root (hd0,0)
grub> kernel /xenimage.gz   [args...doesn't matter which]
Error 13: Invalid or unsupported executable format

This does not seem to be an LBA problem, since the
/boot partition is small, and I'm able to at least
start booting the images I copied from the CD.  (They
won't boot fully, though, and reboot my system
right after saying something like "DOMID is 0".)

Grub is installed from the version 0.93 patched source on
the CD image.  I've built kernels using both the 1.0
CD image (copied to my hard drive, of course) and
the current development snapshot, built via the
supplied xen-clone script as downloaded via BitKeeper.

When I built the kernel without any modifications 
from the CD image, I *still* was unable to get
an image that would boot.  So, I think this is 
something with the modified kernel or perhaps something
related to my particular system.

The kernel build process was otherwise smooth,
and built vmlinux as well as arch/xeno/boot/image.gz
and the xenolinux in an adjacent directory.  

This is on a Dell 530 workstation with 2 1.7Ghz
Xeon processors and 2GB of RAM.  It's basically
a stock SuSE 8.1 installation, with gcc 3.3.

Thanks for any tips or leads.  I've tried things
in many, many different ways across the two
Xen versions, with different kernel configure options, etc.
I tried booting the default vmlinux (before the
multi-boot bytes are prepended), but that kernel
will not boot either via Grub.

At one point, I had a kernel that was too big,
but modularized some of the kernel and got it down
to size.  I was able to make Lilo work (a good
way to see if your kernel seems OK), but at
boot got:

        EBDA too big

and the boot never started.

  -- Greg

Dr. Gregory B. Newby, Research Faculty, Arctic Region Supercomputing Center
University of Alaska Fairbanks.  PO Box 756020, Fairbanks, AK 99775
e: newby@xxxxxxxx v: 907-474-7160 f: 907-474-5494 w: www.arsc.edu/~newby

This SF.net email is sponsored by: SF.net Giveback Program.
Does SourceForge.net help you be more productive?  Does it
help you create better code?   SHARE THE LOVE, and help us help
YOU!  Click Here: http://sourceforge.net/donate/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.