This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Hotplugging SCSI device to Windows 2k3 GOS

To: James Harper <james.harper@xxxxxxxxxxxxxxxx>, "Velayudhan, Vinu" <Vinu.Velayudhan@xxxxxxx>, "Xen-users@xxxxxxxxxxxxxxxxxxx" <Xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] Hotplugging SCSI device to Windows 2k3 GOS
From: "Jose, Manoj" <Manoj.Jose@xxxxxxx>
Date: Wed, 22 Jul 2009 12:39:14 -0600
Accept-language: en-US
Acceptlanguage: en-US
Delivery-date: Wed, 22 Jul 2009 11:40:31 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AEC6C66638C05B468B556EA548C1A77D016DDD22@trantor>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acn4ylBc7pMNGrgNSs6KsBCXDId64AB68G4wAcKdJ1AAArpiAAC14bAQAA9BR4AAIAeUcAA0uEpwABF40/AAHzblMAAO58NwAPIucxA=
Thread-topic: [Xen-users] Hotplugging SCSI device to Windows 2k3 GOS

Thanks for the feedback. I have able to load the 
gplpv_chk_wnet_x86_0.10.0.86.msi on a freshly installed windows 2003 image. But 
hot plugging is still not working for me. 

I have an extra scsi device sdb [0:0:1:0] to test scsi hot plug. I have tried 
following steps. 
1. Started windows 2003 GOS with /gplpv boot option
2. Attached scsi device with following command 
        #xm scsi-attach Windows2003 0:0:1:0 0:0:1:0 

I have seen a Xen SCSI Driver under SCSI and RAID Controllers with a Yellow 
bang. Newly hot plugged device is not seen in Windows 2003 guest OS. My system 
is in this state right now and I have made the system available in RDP. IP 
address is and root password is redhat.

You can find windows GOS image at /usr directory and Xen config file at 
/usr/xen-config-file/ directory. 

Your feed back is very much appreciated. 


-----Original Message-----
From: James Harper [mailto:james.harper@xxxxxxxxxxxxxxxx] 
Sent: Friday, July 17, 2009 6:54 PM
To: Jose, Manoj; Velayudhan, Vinu; Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-users] Hotplugging SCSI device to Windows 2k3 GOS

> James,
> >I'm just uploading a which may or may not fix the problem.
> >If you still get the yellow bang, can you tell me what the failure
> >is when you look at the properties?
> I have tried and that also resulted in the same error.
Properties of
> 'Xen vif device #0' and 'Xen vbd Device #768' says "This device is not
> configured correctly (Code 1).
> >Also, if you are running 3.4.x you should get some debug output in
> >/var/log/xen/qemu-dm-<domu name>.log, please send that to me too.
> I am using xen 3.4.0 and I am attaching the log.

Definitely xenvbd and xennet are not loading correctly or at all.

Are you able to give me rdp access to the domU that the drivers are
installed on?


Xen-users mailing list