This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] 3 failed approaches to create guest domains

To: xen-users@xxxxxxxxxxxxxxxxxxx, fedora-xen@xxxxxxxxxx
Subject: [Xen-users] 3 failed approaches to create guest domains
From: Siddharth Wagh <siddharth.wagh@xxxxxxxxx>
Date: Wed, 11 Feb 2009 16:32:13 -0500
Delivery-date: Wed, 11 Feb 2009 13:33:02 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type; bh=PaKAMCdyk6R/Fh8LF48SMXoVVu8w4bI8W2HxoX03qMo=; b=fM42wP3jSUGC66rshbZ8onJ8dyX5rNqCY1TnyDZa3v/PoqZY7cxquC0heoJk4s9Y68 Pgfx3dkr40elE7iLnWCJJRalMcFZ2mVdiOqWTtwPBLETrooMWZZswxl6WIuhu37WVUn/ y7wO/x+ZlTZaG8WgoQKJ4cAL2E17FzunGr/S8=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=AYAVEbEJT5+m4gwI5wZBeGExcn53oGF0zOKFEhGHjWtziW1TTHVmSW08sGJgZRV650 oQg2borHoZuWi1iWKcwqCO+UKlrggWHASpAVBzlZAqjor6RptQeeZ5W5WeL3Xp6gVxj2 L+bdIfK9ItBj1FOQPvdYIYO91++Rlt/GZkv04=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hello all,

I am a Masters student working on my thesis and have to go use Xen for live migration purposes. I have a Xen installation on Fedora 8, and been trying for past 3 months to create guest domains and get them running for further migration work. I took 3 different approaches, but got stuck with each of those. I would be very grateful if you could point out as to where I am going wrong...

1. Basic command:
xm create -c vm01-config.sxp vmid=1

The config file is kept in /etc/xen folder.

VFS: Cannot open root device "hd0" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

root = '/dev/hd0' or '/dev/hda' or '/dev/sda2'

None worked. I am not sure what the option should be.

2. Using the command:
virt-install -f /etc/xen/xen1 -r 256

Asks for config parameters and creates virtual machine, but I am not sure how to proceed with completion process. In the install location, I put in a  OS image at a mirror site:ERROR:
Unable to find image at given location

This is the only approach which creates a VM, but the machine is not completely running (not functional or doesnt consume any memory). Am I supposed to have the guest image on my machine?

3. Using "virt-manager" in GUI

ERROR: Asks for "Connect to host  network" but "shared physical devices" list is empty. It is supposed to list eth0, peth0 etc. Something to do with creating a bridge. I tried the approach of NAT, but for that I have to use approach 1 to create a machine, which gets stuck on "root" error.

Libvirtd is not running. It gave the message:

libvir: Remote error : Connection refused
libvir: warning : Failed to find the network: Is the daemon running ?
libvir: Remote error : Connection refused

xend is running, I checked status.

If anyone could devote a little of their time to help me out, as I am not comfortable with kernel administration/OS admin, I would be really thankful.

Thanks & Regards,
Siddharth Wagh
To ensure perfect aim, shoot first and call whatever you hit the target...
Xen-users mailing list