This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: [Fedora-xen] 3 failed approaches to create guest domains

To: Siddharth Wagh <siddharth.wagh@xxxxxxxxx>
Subject: [Xen-users] Re: [Fedora-xen] 3 failed approaches to create guest domains
From: Olivier Renault <orenault@xxxxxxxxxx>
Date: Thu, 12 Feb 2009 20:48:54 +0100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx, fedora-xen@xxxxxxxxxx
Delivery-date: Thu, 12 Feb 2009 21:47:15 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <ad4b80f30902111332p5919f63egf727705028c47d37@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <ad4b80f30902111332p5919f63egf727705028c47d37@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20090105)
Siddharth Wagh wrote:
Hello all,

I am a Masters student working on my thesis and have to go use Xen for live migration purposes. I have a Xen installation on Fedora 8, and been trying for past 3 months to create guest domains and get them running for further migration work. I took 3 different approaches, but got stuck with each of those. I would be very grateful if you could point out as to where I am going wrong...
1. Basic command:
xm create -c vm01-config.sxp vmid=1*

The config file is kept in /etc/xen folder.

VFS: Cannot open root device "hd0" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

root = '/dev/hd0' or '/dev/hda' or '/dev/sda2'

None worked. I am not sure what the option should be.

2. Using the command:
virt-install -f /etc/xen/xen1 -r 256*

Asks for config parameters and creates virtual machine, but I am not sure how to proceed with completion process. In the install location, I put in a OS image at a mirror site:


Unable to find image at given location

This is the only approach which creates a VM, but the machine is not completely running (not functional or doesnt consume any memory). Am I supposed to have the guest image on my machine?

*3. Using "virt-manager" in GUI*

ERROR: Asks for "Connect to host network" *but "shared physical devices" list is empty*. It is supposed to list eth0, peth0 etc. Something to do with creating a bridge. I tried the approach of NAT, but for that I have to use approach 1 to create a machine, which gets stuck on "root" error.

Libvirtd is not running. It gave the message:

libvir: Remote error : Connection refused
libvir: warning : Failed to find the network: Is the daemon running ?
libvir: Remote error : Connection refused

xend is running, I checked status.

Commenting on method 2:

If you have got a iso of F8 DVD somewhere, mount it loopback on /var/www/html/pub & start your web server

# mount -o loop F8.iso /var/www/html/pub
# service httpd start

Then you should be able to do the installation

         # virt-install \
              --paravirt \
              --name demo \
              --ram 500 \
              --file /var/lib/xen/images/demo.img \
              --file-size 6 \
              --nographics \
              --location http://ip of your web server/pub

Good luck.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>