This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Still having problems with xen guest boot

To: "Octavian Teodorescu" <octav@xxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] Still having problems with xen guest boot
From: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
Date: Wed, 30 May 2007 16:27:33 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 30 May 2007 07:26:08 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <64704.>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AceixV0PdQgk+ep0QkWVMDL29Rae+wAAE4Uw
Thread-topic: [Xen-users] Still having problems with xen guest boot

> -----Original Message-----
> From: Octavian Teodorescu [mailto:octav@xxxxxxxxxxxxxxxx] 
> Sent: 30 May 2007 15:19
> To: Petersson, Mats
> Subject: RE: [Xen-users] Still having problems with xen guest boot
> Ok. Sorry for sending mails not so well detailed.
> So:
> about lomount, it's the first time I have heard of it :)
> I always used mount. From what I've seen so far it seems to me that
> lomount just mounts images not logical volumes.

Yes, that's correct. I'm not particuarly familiar with volume groups, so
you may find better advice than mine from searching the Xen Users list
looking for how to set up volume groups - but as far as I understand it,
the volume group stuff is all hidden from the guest under normal
circumstances, and you should be able to mount the guest's filesystem in
your Dom0 in one way or another (assuming of course the guests
filesystem is supported in Dom0, which isn't necessary at all - they all
appear like block-devices from Dom0's standpoint, and DomU is
responsible for deciding what the content of the blocks actually mean,
e.g. directory structures, free-block-lists, etc, etc). 

> Because I've tried earlier to mount it manually and received 
> errors. Know
> it is not mounted when I'm doing xm create -c ns1. It just 
> has an entry in
> /etc/fstab:
> /dev/VGvhosts/root.ns1 /vhosts/ns1             ext3    
> defaults        0 0
> /dev/VGvhosts/swap.ns1 swap                    swap    
> defaults        0 0

So this is the devices for your guest, listed in Dom0's fstab, yes? You
shouldn't need to have any information for the guest within Dom0 outside
of the guest configuration file. Although the case where the guest
filesystem is mounted to Dom0 should be detected by the create-script,
so that's unlikely to be your problem. 

I'm not that familiar with the setup for para-virtual, so if I'm not
helping very directly, I'm sorry. I'm just trying to guide you as best
as I can. There are others who have more experience than me on setting
up paravirtual domains - anyone who thinks they have better advice,
please pipe in. 

> >>
> >>
> >>> -----Original Message-----
> >>> From: Octavian Teodorescu [mailto:octav@xxxxxxxxxxxxxxxx]
> >>> Sent: 30 May 2007 15:04
> >>> To: Petersson, Mats
> >>> Subject: RE: [Xen-users] Still having problems with xen guest boot
> >>>
> >>> Ok, made what you said, and the same. In the ns1 config file
> >>> I have added:
> >>> ramdisk = "/boot/initrd-2.6.18-8.1.4.el5xen.img"
> >>> Which I have made with:
> >>> mkinitrd -v -f --with=ext3 --with=xenblk
> >>> /boot/initrd-2.6.18-8.1.4.el5xen.img 2.6.18-8.1.4.el5xen
> >>>
> >>> And the same error:
> >>> xm create ns1 -c
> >>> Using config file "./ns1".
> >>> Error: destroyDevice() takes exactly 3 arguments (2 given)
> >>
> >> This error is caused by the guest being killed, most 
> likely because you
> >> don't have the right drivers in your initrd. It's no point 
> in posting
> >> more xend-logs. A log of the console of the guest may be 
> more useful.
> >> Although if it's still the same as your previously posted 
> ones, then it
> >> may not help much.
> >>
> >> By the way, is your guest-filesystem mountable on your Dom0 using
> >> something like "lomount"?
> >>
> >> --
> >> Mats
> >>
> >>
> >>

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>