[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v4 2/3] bitmap: import bitmap_{set/clear} from Linux 5.5

On 14.02.2020 11:40, Roger Pau Monné wrote:
> On Mon, Feb 10, 2020 at 12:54:04PM +0000, Julien Grall wrote:
>> On 10/02/2020 12:32, Jan Beulich wrote:
>>> On 10.02.2020 13:21, Julien Grall wrote:
>>>> Hi,
>>>> On 10/02/2020 11:59, Jan Beulich wrote:
>>>>> On 10.02.2020 12:00, Julien Grall wrote:
>>>>>> On 10/02/2020 10:28, Jan Beulich wrote:
>>>>>>> On 10.02.2020 10:45, Julien Grall wrote:
>>>>>>>> Please suggest a new name for BIT_WORD() and we can repurpose it. So
>>>>>>>> far, I have no idea how to rename it.
>>>>>>> _BIT_WORD() if you/we were to accept the name space violation, or
>>>>>>> BITMAP_WORD()?
>>>>>> BITMAP_WORD() is misleading as bitmap are using unsigned long. So my
>>>>>> preference is _BIT_WORD().
>>>>>> Another alternative would be ATOMIC_WORD().
>>>>> Except that there are also non-atomic bitmap operations, I don't really
>>>>> care about the name as long as it's not BIT_WORD() (or anything else
>>>>> that's likely to collide with other stuff.
>>>> I am afraid we are disagreing on what is colliding with what here. The
>>>> naming on Arm has been like that for the past few years. While this may
>>>> not have been the best choice, this is your suggestion colliding with
>>>> what is existing.
>>> It is a plain import from Linux which has turned out impossible
>>> because of the change that was done at some point to Arm code
>>> which, I guess, also originally came from Linux. There's no new
>>> naming I've been suggesting here at all.
>> We never claimed we would be fully compatible with Linux and I don't think
>> we could every claim it. Particularly, the bitop operations are different
>> given Linux bitops are based on unsigned long.
>> The bitop did indeed came from Linux originally, however we had to adapt
>> them because Linux Armv8 bitop was expecting 8-byte aligned. This does not
>> hold on Xen.
>>>> I am not entirely fussed about the namespace violation, although I think
>>>> the name is potentially misleading. Yet, I would be happy to use
>>>> _BIT_WORD() as this is the best of it so far.
>>>> While this is code falls under Arm maintainership, I am still happy to
>>>> consider other naming. But at this point, you should be the one suggesting.
> So I assume you would like me to import bitmap_{set/clear} and use it
> in the x2APIC MSR patch?

Well, it's really up to you. I've put this as an item on my own todo
list already, assuming there may be more places where the two functions
might turn out useful.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.