[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v4 2/3] bitmap: import bitmap_{set/clear} from Linux 5.5

On 10/02/2020 10:28, Jan Beulich wrote:
On 10.02.2020 10:45, Julien Grall wrote:
Please suggest a new name for BIT_WORD() and we can repurpose it. So
far, I have no idea how to rename it.

_BIT_WORD() if you/we were to accept the name space violation, or

BITMAP_WORD() is misleading as bitmap are using unsigned long. So my preference is _BIT_WORD().

Another alternative would be ATOMIC_WORD().


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.