[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v4 2/3] bitmap: import bitmap_{set/clear} from Linux 5.5


On 10/02/2020 11:59, Jan Beulich wrote:
On 10.02.2020 12:00, Julien Grall wrote:
On 10/02/2020 10:28, Jan Beulich wrote:
On 10.02.2020 10:45, Julien Grall wrote:
Please suggest a new name for BIT_WORD() and we can repurpose it. So
far, I have no idea how to rename it.

_BIT_WORD() if you/we were to accept the name space violation, or

BITMAP_WORD() is misleading as bitmap are using unsigned long. So my
preference is _BIT_WORD().

Another alternative would be ATOMIC_WORD().

Except that there are also non-atomic bitmap operations, I don't really
care about the name as long as it's not BIT_WORD() (or anything else
that's likely to collide with other stuff.

I am afraid we are disagreing on what is colliding with what here. The naming on Arm has been like that for the past few years. While this may not have been the best choice, this is your suggestion colliding with what is existing.

I am not entirely fussed about the namespace violation, although I think the name is potentially misleading. Yet, I would be happy to use _BIT_WORD() as this is the best of it so far.

While this is code falls under Arm maintainership, I am still happy to consider other naming. But at this point, you should be the one suggesting.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.