[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xl console regression on xen-unstable

Il 15/10/2013 16:18, Fabio Fantoni ha scritto:
Il 15/10/2013 11:45, Wei Liu ha scritto:
On Tue, Oct 15, 2013 at 10:16:09AM +0100, Ian Campbell wrote:
On Mon, 2013-10-14 at 16:26 +0100, Wei Liu wrote:
On Mon, Oct 14, 2013 at 04:57:48PM +0200, Fabio Fantoni wrote:
Il 14/10/2013 16:29, Wei Liu ha scritto:
On Mon, Oct 14, 2013 at 04:21:52PM +0200, Fabio Fantoni wrote:
Il 14/10/2013 16:02, Wei Liu ha scritto:
On Tue, Oct 08, 2013 at 04:47:17PM +0200, Fabio Fantoni wrote:
I'm unable to start xl console on latest xen-unstable (build with
commit 8e0da8c07f4f80e14314977a11f738bd74a5b62b).
xl -vvv console sid
xenconsole: Could not read tty from store: No such file or directory
It would be good if you can paste the output here.
Thanks for reply.
The "xenconsole: ..." line is the only output of "xl -vvv console
sid" command, before that it shows nothing for some seconds, then
return to command line.

I also tried "xl create -c", and it shows console from pygrub but
when the "xl create" reaches the end I got the same error:
xenconsole: Could not read tty from store: No such file or directory
Please run xl -vvv create -c, paste output here.
See on attachment.

Could you also attach the output of "xenstore-ls" when your DomU is up
and running.
See attachment.

Thanks for any reply.

That's weird. Xenstore-ls log's tty= field is empty while there's no
complain about writing console node in xl -vvv create log.
xenconsoled writes that node IIRC.

Right, then there should be some info in xenconsoled's log. I wasn't
paying attention to that part because there doesn't seem to be
significant change.

It's possible that this is a kernel side bug? In that the console is not
created because of something going on on the guest side.

Fabio, can you check the log of xenconsoled? Is it running normally?

It's a bit hard for me to imagine a guest kernel side bug causing
xenconsoled to misbehave, but that's also possible. If xenconsoled is OK
please follow Ian's suggestion to provide more info.


I not found xenconsoled log, it seems not running: "ps ax | grep xenconsoled" returns nothing and the /var/run/xenconsoled.pid has stored pid of died process. I tried to restart xenconsoled manually and after that xl console returns working. I'll do a completly fresh system on the next days and I will let you know.

I did a full clean test system and for now xenconsoled is not crashed.
I will keep xl console tested more often to find the cause if re-happen.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.