[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] efibootmgr not working on xen-unstable booted on uefi system

>>> On 31.05.12 at 11:41, Fabio Fantoni <fantonifabio@xxxxxxxxxx> wrote:
> Il 30/05/2012 10:44, Jan Beulich ha scritto:
>>>>> On 30.05.12 at 10:03, Fabio Fantoni<fantonifabio@xxxxxxxxxx>  wrote:
>>> The content of xen/arch/x86/efi/disabled is:
>>> ld: unrecognised emulation mode: i386pep
>>> Supported emulations: elf_x86_64 elf32_x86_64 elf_i386 i386linux
>>> elf_l1om elf_k1om
>>> How can I do for fix this?
>> If your distor doesn't offer a suitably configured binutils package,
>> you'll have to build one yourself, I'm afraid.
>> Jan
>> -----
>> Nessun virus nel messaggio.
>> Controllato da AVG - www.avg.com 
>> Versione: 2012.0.1913 / Database dei virus: 2425/5032 -  Data di rilascio: 
> 29/05/2012
> Currently I'm testing xen-unstable on Debian Wheezy, I installed 
> binutils-mingw-w64 package that provide binutils with i386pep emulation, 
> I tried to rebuild but I had same error on xen/arch/x86/efi/disabled.
> The ld binary provided with this package has a different name, what can 
> I do to make xen use it instead of the default one? (/usr/bin/ld)
> I loocked for $(LD) definition used in makefile but I didn't found it.
> Thanks for any reply.

Setting LD can be done on the make command line (you shouldn't
modify any sources for this). I don't think, however, that using a
mingw targeting binary will work, as the *same* ld will be used to
link the normal ELF executable (ending up as xen.gz). You should
use a Linux linker (i.e. defaulting to ELF) that *also* supports
i386pep. (Building binutils is, btw, a pretty simple process, so I
don't see why you're not just doing that - all customization you
need is adding "--enable-targets=x86_64-pep" to the configure
script invocation command line.)


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.