[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen 4.1.1 + 3.0.0-rc5 dom0 + blktap2

On 29.06.2011 04:32, Daniel Stodden wrote:
On Tue, 2011-06-28 at 22:08 -0400, SÃbastien Riccio wrote:

I'm currently trying xen 4.1.1 with the 3.0.0-rc5 (heard that it now
contains the xen code to run as front or back xen domain).

Everything seems to run fine, except that I am trying since a  few hours
to mount a .vhd file in the dom0.

What I tried so far:

to create a blank vhd file (this is working):
host# vhd-util create -n /storage/test.vhd -s 20G

Then i try to mount the file in dom0 (as stated in a blktap2 README file)
host# tapdisk2 -n vhc:/storage/test.vhd
tap-ctl create -n vhd:/storage/test.vhd # :)

As a rule of thumb, there's no excuse to call tapdisk2 on the command
line. Should actually rather have gone into libexec.


Hi Daniel,

Thank you for your help. With this command I still get into the
"blktap kernel module not installed"

I'm using xen 4.1.1 compiled from source with a kernel 3.0.0-rc5 dom0 (compiled with all xen stuff enabled). Is there missing xen modules in the new kernel ? I try to use most recent xen enabled kernel. Is there a 2.3.29
xenfified kernel around ?

Thanks again,

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.