[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] xen 4.1.1 + 3.0.0-rc5 dom0 + blktap2


I'm currently trying xen 4.1.1 with the 3.0.0-rc5 (heard that it now contains the xen code to run as front or back xen domain).

Everything seems to run fine, except that I am trying since a few hours to mount a .vhd file in the dom0.

What I tried so far:

to create a blank vhd file (this is working):
host# vhd-util create -n /storage/test.vhd -s 20G

Then i try to mount the file in dom0 (as stated in a blktap2 README file)
host# tapdisk2 -n vhc:/storage/test.vhd

it fails, returning:
tapdisk2: invalid option -- 'n'
usage: tapdisk2 <-u uuid> <-c control socket>

Then i've tried:
host# tap-ctl  list

It returns:
blktap kernel module not installed

Then tried too:
host# xl block-attach 0 tap:vhd:/storage/test.vhd xvda w 0

It does not complain but nothing happens.

Am I getting something wrong about how to do it ? Does the 3.0.0-rc5 kernel is missing something ? (look like there is no blktap module in the kernel tree, but blkback that I enabled, don't know if it's the same)

I have no more ideas about what to try next. Any clue ?

Thanks a lot for your help!

Kind regards,

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.