[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

I've got things running on a number of systems now, and have tried a
number of combinations. I have changed machines and USB memory sticks,
and the fault seems to be related to the machine rather than the memory
stick. I have 3 machines with >4GB ram & 2 memory sticks, changing
memory sticks doesn't have any effect, but only two out of the three
machines I tried has a problem, the third works fine.

I have previously attached the lspci -vvv for one of the machines that
fails, and the lspci -vvv for the second machine is attached to an email
relating to the screen corruption problems I was having a few days ago
(Screen corruption and crash at boot with Xen 4.1.0 & linux 2.6.39 on
some systems).



On 02/06/2011 15:44, Konrad Rzeszutek Wilk wrote:
> On Thu, Jun 02, 2011 at 10:38:07AM -0400, Konrad Rzeszutek Wilk wrote:
>> On Thu, Jun 02, 2011 at 01:24:56PM +0100, Anthony Wright wrote:
>>>> Do you get the same problem if you boot baremetal and do 'iommu=soft' 
>>>> (without the mem=4G)? You should see the same error.
>>> I'm not quite sure what you mean by "boot baremetal", but I've just done a 
>>> boot where I removed the mem=4096M options from the Xen boot line and added 
>>> an 'iommu=soft' option. The result of this was a corrupt USB device again.
>> Baremetal = no Xen.
>>>> Can you attach your lspci -vvv output too please?
>>> attached.
>>>> This is the motherboard you have right?
>>>> http://www.newegg.com/Product/Product.aspx?Item=N82E16813131613
>>> Yes that's the motherboard.
> I've an BIOSTART motherboard that looks to have a similar EHCI controller - 
> MCP61 based.
> Is the USB stick that you are using any special? Or is just a normal one?

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.