[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

On 02/06/2011 15:44, Konrad Rzeszutek Wilk wrote:
> On Thu, Jun 02, 2011 at 10:38:07AM -0400, Konrad Rzeszutek Wilk wrote:
>> On Thu, Jun 02, 2011 at 01:24:56PM +0100, Anthony Wright wrote:
>>>> Do you get the same problem if you boot baremetal and do 'iommu=soft' 
>>>> (without the mem=4G)? You should see the same error.
>>> I'm not quite sure what you mean by "boot baremetal", but I've just done a 
>>> boot where I removed the mem=4096M options from the Xen boot line and added 
>>> an 'iommu=soft' option. The result of this was a corrupt USB device again.
>> Baremetal = no Xen.
Tried a baremetal boot (no Xen) with ''iommu=soft" on the linux command
line, and the USB reads fine.
> I've an BIOSTART motherboard that looks to have a similar EHCI controller - 
> MCP61 based.
> Is the USB stick that you are using any special? Or is just a normal one?
It's a Kingston DataTraveler G2 (2GB). It's the cheapest memory stick I
could find at the time, nothing special as far as I know.

I'll try to get the kernel sorted out to get around the screen
corruption tonight, and try on another system tomorrow and with a
different memory stick too.



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.