[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Invalid or unsupported executable format, or is it a reiserfs problem?

Our newly build xen kernel does not boot. The error message is : Invalid or unsupported executable format.

I have build xen from the xen-2.0.4 source (make world, make install) on a debian sarge system.
I have not changed any of the kernel configurations, I did make an initrd image.
The entry in my menu.lst is :

title           Debian GNU/Linux, kernel 2.6.10-xen0
root            (hd0,0) # I also tried without this line.
kernel          /boot/xen.gz dom0_mem=64000
module          /boot/vmlinuz-2.6.10-xen0 root=/dev/hda1 ro
module          /boot/initrd.img-2.6.10-xen0 # Also tried without this line

The server's / (/boot) partition is reiserfs. I wonder if this is the problem? I found messages saying that it doesn't work with reiserfs and others that say it should work. What is the final answer?
Looking in the kernel config file: reiserfs is build into the kernel, not as a module.
As a side note: the standard debian 2.6.8-2 kernel works perfectly.

== from the grub manual ==
Invalid or unsupported executable format:
This error is returned if the kernel image being loaded is not recognized as
Multiboot or one of the supported native formats (Linux zImage or bzImage,
FreeBSD, or NetBSD).
== end ==
since xen is multiboot and I would be surprised that the xen.gz kernel image file is not in native format; I have a strong feeling that this error message is not giving the root cause.

Anybody any thoughts?

Thanx in advance for any answer,


Filip Sergeys
* System Engineer, Verzekeringen NV *
* www.verzekeringen.be              *
* Oostkaai 23 B-2170 Merksem        *
* 03/6416673 - 0477/340942          *



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.