[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen 2.0 testing idle_loop -and -03

1) extreme slowness

Is this in DOM0 or some other domain? If it looks like I/O slowness,
have any network or disc microbenchmarks (e.g., net/disc bandwidth or
latency) got much worse?

dom0, i tried to compile kernel and it was like 10-100 times slower... but I got impression that it was because the disk was heavily trashing.. it seemed like the 45 out of the 65mb disappeared somewhere, and the remainining 15 was just not enough to compile kernel (in fact oom-killer killed my sshd twice).

2) won't boot on p3 with compiled for for cyrix

Has that ever worked? I did recently fix a problem with
CONFIG_X86_USE_3DNOW, so were you testing a very up to date version of
the repository? If you are totally stuck send me your .config and I
can build and test.

yeah, it worked just fine on xen 2.0 release. I could compile kernel with CONFIG_MCYRIXIII and then run the same kernel on both P3 and via (with some special patches). This time the kernel bombed on P3 (have not tried it on via).

the repository was as of yesterday.

3) "idle_loop" gets optimized away

Okay I fixed this now.

I did a push from -testing to teh stable tree yesterday
(v2.0.2). There are already a couple more fixes added to the -testing
tree since then so I expect we will end up doing a 2.0.3 release
fairly soon (there are a few other problems we would like to get fixed
first, so it will probably be early in the new year).


SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. http://productguide.itmanagersjournal.com/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.