[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] problem with booting

  • To: "'Devel Xen'" <xen-devel@xxxxxxxxxxxxxxxxxxxxx>
  • From: "Dave Berlin" <dave@xxxxxxxxxxxxxx>
  • Date: Sat, 22 Nov 2003 20:59:25 -0800
  • Delivery-date: Sun, 23 Nov 2003 05:00:13 +0000
  • Importance: Normal
  • List-id: List for Xen developers <xen-devel.lists.sourceforge.net>

There is 256MB of physical RAM in the machine.

Here is the GRUB entry:

title Xen / Xenolinux 2.4.22
        kernel /xen.gz dom0_mem=131072 ser_baud=115200 noht
        module /xenolinux.gz root=/dev/sda4 ro console=tty0

We have also tried using hda0 and hda1 instead of sda4 as we weren't sure
what that meant.

The last few lines of the error message are:

megaraid: v1.18d (release date: Wed Aug 7 18:51:51 EDT 2002)
megaraid: no BIOS enabled
device eth0 opened and ready for use

Could not set up dom0 guest OS
Aieee! CPU0 is toast.

Please let us know if you need more of the error message, and thanks again
for your help. Also, if you need more of the error message, is there any way
to keep it from rebooting after only 5 seconds? It is difficult to copy a
lot down in that small window.

Dave Berlin
Jefferson Ng
Jeremy Chiu

-----Original Message-----
From: Bin Ren [mailto:br260@xxxxxxxxx] 
Sent: Saturday, November 22, 2003 2:32 AM
To: Dave Berlin
Cc: Devel Xen
Subject: Re: [Xen-devel] problem with booting

On 22 Nov 2003, at 05:06, Dave Berlin wrote:

> We have read the readme and have been following it step by step.  
> We?ve come across a problem when booting into xen using grub.  When 
> selecting Xen from the grub loader, we get the message ?DOM0 refused 
> to load, Aieee!? (or something to that effect)
> We have tried using the suggested menu.lst, and have also tried 
> replacing the root=/dev/sda4 with root=/dev/hda1 and root=/dev/hda2, 
> the names of the root and boot partitions respectively.  Do you have 
> any suggestions on things to check for?  Xen.gz and xenolinux.gz are 
> both in the /boot directory, and the xen kernel seems to start.

Please post to this list the last several lines of boot messag, and
the GRUB menu entry for XenoLinux.

There could be various reasons for this error. Before having further
information, let's try the simplest one:

How much physical memory in total does your machine have?
How much physical memory have you assigned to Domain0 in the
GRUB menu entry?

-- Bin

This SF.net email is sponsored by: SF.net Giveback Program.
Does SourceForge.net help you be more productive?  Does it
help you create better code?  SHARE THE LOVE, and help us help
YOU!  Click Here: http://sourceforge.net/donate/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.