This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] XCP: how to connect to VNC term of new VM (was: VM insta

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] XCP: how to connect to VNC term of new VM (was: VM installation in XCP 0.5 is behaving strangely)
From: George Shuklin <george.shuklin@xxxxxxxxx>
Date: Mon, 23 Aug 2010 02:29:32 +0400
Delivery-date: Sun, 22 Aug 2010 15:32:19 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:subject:from:to:in-reply-to :references:content-type:date:message-id:mime-version:x-mailer :content-transfer-encoding; bh=2Yntg+3ePc7lIYaL8nv2KZ4ceoSyyc8ASwbGnmwC0b4=; b=sdt5RiA95TE3z8vmFOlXefnQsXn7KcKefsi49zAFfp8NHJo9CnOrJEFL94n1FEPUWD 4OhSlOXq5EcITKIBmFSAQpNEInxVoNxAgw9xIBKbuVVnhLaZhvYc05a45uMwlXYW/d1z 8xoep73ejbB4ezAML3ohhXESQqDzY4qK56t/o=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=subject:from:to:in-reply-to:references:content-type:date:message-id :mime-version:x-mailer:content-transfer-encoding; b=qihKbiAsCBNxI1P42JQ2dT8+xnwkwMksGtuPRmz+LOLXQUFGTBDdYm6o4DN3HGaJzc HG1lLRt2K/a2zmDzXWip6mLgM/wsULajv9RszmV1VcvF7baMboB6t+YoEt0SN54NRjAa bQfnWviDBJJ65d8AJy8URGIX5OBF9rAToB8rY=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4FCE7DAE-9D6E-4AC4-8CDC-8F9DCF1B5C62@xxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <3CD3518F-FD45-4954-A986-EBFB77D09351@xxxxxx> <1282493025.18210.0.camel@xxxxxxxxxxxxxxxx> <4FCE7DAE-9D6E-4AC4-8CDC-8F9DCF1B5C62@xxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Yes, if vm-start return nothing in reasonable time it sign that all ok
(if not ok it will start to say something like 'pygrub no bootable disk
found", etc).

There is three different way to continue system setup.

First: create preseed/kickstart file. Hard to make from scratches and
postinstall debug.

Second: Access to VNC console via openxencenter. It really not very good
from my point of view, because not working (last time I test it few
month ago) with slave hosts.

Third: my favorite. Create SSH tunnel to localhost: ssh -L
5901: -L 5902: ... -L 5999:

(this command must be run as root). After that you can connect to
vncterm, listening on localhost on XCP host. 

You can found requied VNC port from xenstore:
xe vm-list uuid=vmuuid params=dom-id  (here you got domID for VM)
xenstore-ls /local/domain/<DOMIDFROMLINEABOVE>/serial/0
(f.e. 5904)

... and connect to those port via xvncviewer from your own linux desktop
(you are using linux at you desktop, isn't it?):

xvncviewer localhost:5904 (or other port from xenstore-ls).

Note: every time VM migrating, restarting or stop/starting you must
refound again port number.

В Вск, 22/08/2010 в 15:01 -0700, Yueyu Lin пишет:
> Ops, I think the network is set up automatically.
> Now I've already set up the vif for the virtual machine and when I start the 
> vm, it just behaves the same
> I think I misunderstand something. 
> after 
> xe vm-start uuid=UUID
> the command return with nothing.
> Should I use something like openxencenter to connect the console to continue 
> installing?
> I list the vm status, it seems it's running.
> But in Mac OS X, I can't manage to install the openxencenter for now. I hope 
> I can ssh or telnet the virtual machine.
> Is there other way to access the console without openxencenter?
> On Aug 22, 2010, at 9:03 AM, George Shuklin wrote:
> > You forgot to create vif for virtual machine (not network interface, no
> > network boot).
> > 
> > В Вск, 22/08/2010 в 04:56 -0700, Yueyu Lin пишет:
> >> Hi, all
> >>  I'm totally new to XCP, so maybe i misunderstood the documentation. 
> >>  I tried to create Debian Squeeze (64-bit) and Ubuntu 10.04 from templates 
> >> and install them from network installation.
> >>  For Debian Squeeze (64-bit), I did the followings:
> >> 
> >>  1. First ssh login into XCP host
> >>  2. xe vm-install template="Debian Squeeze (64-bit)" 
> >> new-name-label=lenny-64-netinstall
> >>  Get the UUID from the output
> >>  3. xe vm-param-set uuid=UUID 
> >> other-config:install-repository=http://ftp.us.debian.org/debian/
> >>  Set the repository as debian US mirror
> >>  4. xe vm-start uuid=UUID
> >> 
> >>  Then the ssh terminal start to freeze there and it will never prompt 
> >> anything as documentation said "install step by step".
> >>  I doubted if the installation can only be done in the physical host, so I 
> >> tried to do this in the physical host. But the same 
> >>  thing happened. 
> >>  After sometime freezing, the prompt returned and gave me nothing. While I 
> >> run xe vm-list, the vm's status shows running.
> >>  I'm totally frustrated. I don't what I've missed since I just followed 
> >> the manual and saw no error log output.
> >> 
> >>  Can someone point out where I did wrong? 
> >> 
> >>  Thanks a lot!
> >> 
> >> _______________________________________________
> >> Xen-users mailing list
> >> Xen-users@xxxxxxxxxxxxxxxxxxx
> >> http://lists.xensource.com/xen-users
> > 
> > 
> > 
> > _______________________________________________
> > Xen-users mailing list
> > Xen-users@xxxxxxxxxxxxxxxxxxx
> > http://lists.xensource.com/xen-users

Xen-users mailing list