This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen-unstable unable to see (any) network card

To: James Blackwell <jblack@xxxxxxxxxxxxx>
Subject: Re: [Xen-users] Xen-unstable unable to see (any) network card
From: Yvette Chanco <yentlsoup@xxxxxxxxx>
Date: Fri, 10 Jun 2005 12:00:03 -0500
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 10 Jun 2005 16:59:14 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=UvJf6GT3rZ98AU1Qa3LtfzTuGYRM6Gkk2YhMscbiVA+9SkPPSyS2KCRoDz+/REIidKQKcNq10WXMn8MKF7U3oQzrP5DKt0j8h6w6wduSgBgiGic59bbNOxvpgKnF9eGBEa9qFEDZe8CaRHiJRavEeGEu91P+M+afhyx4gtPcdF8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20050609040013.GA19580@xxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20050609040013.GA19580@xxxxxxxxxxxxx>
Reply-to: Yvette Chanco <yentlsoup@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Unfortunately I don't have the immediate answer to your problem, but I
can say that
the age of hardware should not be an issue in and of itself (although
there can always be issues with specific hardware, and I imagine that
somebody else would probably ask you the details of your network
cards, hardware, dmesg, etc., so you might want to post them). We have
Xen (with debian testing/sarge 3.1r0 as a base) running on older
machines (two PIIs, one  350 mgz with 192 mb of ram). My primary
"test" machine has 384 mb of ram and a 900 mhz processor.

Have you tried the Xen demo live cd on the box in question? I haven't
tested 2.0.6 fully, but the 2.0.5 demo was very useful for
troubleshooting, since it supports a lot more hardware than the plain
vanilla installs (and will work on a machine with 256 mb of ram in
text-only mode).

I've also tried most of the installs that you have (except the Debian
unstable version, isn't that Xen 1.2?) with success after some
tweaking - I could give details, but this post is already rather long,
since I'm not actually solving your problem, just commenting on it.

On 6/8/05, James Blackwell <jblack@xxxxxxxxxxxxx> wrote:
> Hello!
> Xen seems like a neat idea -- such a neat idea that I rushed downstairs,
> wiped clean one of my computers with a fresh Debian 3.0 install, and tried
> installing various xen-.*-install.tgzs on the machine. Sure, the machine
> only has 256 megs of ram and a 900mhz processor, but it'll be a
> _mainframe_
> I failed miserably. I tried xenophilia (failed), the xen in Debian
> unstable (failed) xen-2.0.[46]-install.tgz and xen-unstable (7 June and 5
> June).
> In each case it was an interrupt problem; for one of them, hda had irq
> timeouts.  For another (I think this was laura/xen 2), none of the three
> network cards I tried showed up at all (including in lspci).
> In the case of xen-unstable-install everything seemed to work -- the irq
> for hda was found, the various nics were found. However, the nics didn't
> work because of send timeouts; I would paraphrase the error as:
> 'NETDEV WATCHDOG: eth0 timeout on transmit'
> I tried adding various kernel options to the pertinant stanza in grub's
> menu.lst, at one time trying to add options to the kernel line, other
> times trying the module line. The options I tried were the following:
> noapic, acpi=off, pciirq=bios, and a couple others.
> I figure the main problem is that the computer I tried xen on is pretty
> old -- probably around 5 years.  Would that be a factor?
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

-Yvette Chanco

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>