This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Xen-unstable unable to see (any) network card

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Xen-unstable unable to see (any) network card
From: jblack@xxxxxxxxxxxxx (James Blackwell)
Date: Thu, 9 Jun 2005 00:00:14 -0400
Delivery-date: Thu, 09 Jun 2005 13:26:11 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.6+20040907i

Xen seems like a neat idea -- such a neat idea that I rushed downstairs,
wiped clean one of my computers with a fresh Debian 3.0 install, and tried
installing various xen-.*-install.tgzs on the machine. Sure, the machine
only has 256 megs of ram and a 900mhz processor, but it'll be a

I failed miserably. I tried xenophilia (failed), the xen in Debian
unstable (failed) xen-2.0.[46]-install.tgz and xen-unstable (7 June and 5

In each case it was an interrupt problem; for one of them, hda had irq
timeouts.  For another (I think this was laura/xen 2), none of the three
network cards I tried showed up at all (including in lspci). 

In the case of xen-unstable-install everything seemed to work -- the irq
for hda was found, the various nics were found. However, the nics didn't
work because of send timeouts; I would paraphrase the error as:
'NETDEV WATCHDOG: eth0 timeout on transmit'

I tried adding various kernel options to the pertinant stanza in grub's
menu.lst, at one time trying to add options to the kernel line, other
times trying the module line. The options I tried were the following: 
noapic, acpi=off, pciirq=bios, and a couple others. 

I figure the main problem is that the computer I tried xen on is pretty
old -- probably around 5 years.  Would that be a factor? 

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>