This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Cannot open root device

ok.... got it working.

So, the devices in the config file are valid for the guest OS only and not the host. Thanks Lyndsay.

This config works now:
kernel = "/boot/vmlinuz-2.6-xenU"
memory = 64
name = "ttylinux2"
vif = [ 'mac=aa:00:00:00:00:11, bridge=xen-br0' ]
disk = [ 'file:/etc/xen/ttylinux-xen,sda1,w' ]
root = "/dev/sda1 ro"
extra = "4"

Did not do anything else yet, but have it booting at last :-)

Now where to get another image file to play with e.g. Centos.

Thanks for the help!


Lyndsay Roger wrote:
On Sun, 2005-06-05 at 09:08 +0200, Hsing-Foo Wang wrote:

Yes I did, since I have scsi I tried sda1 too but no luck
Then again I am a bit confuse on what to use with 'file:....'
Do I point to the mountpoint or the ttylinyx-xen image file? Again tried both, but no luck.

Also, the line 'root = "/dev/md1"' should this be point to the real host device which in my case is /dev/md1?

The lines from one of my config files are -
disk = [ 'phy:hda5,hda1,w' , 'phy:hda6,hda2,w' ]
and root = "/dev/hda1 ro"

The root line tells the guest where to find its root filesystem.

I use partitions (never tried to use a file) but by looking at the doc's
you should use the /full/path/and/filename to the ttylinux file in the
dom0 file system.

As far as I know it should not matter if you use hda1 or sda1 as what
ever you use is what the guest will see and the guest does not see the
actual underlying hardware. Someone please correct me if I am wrong :-)


Xen-users mailing list