This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Cannot open root device

To: Lyndsay Roger <gombadi@xxxxxxxxx>
Subject: Re: [Xen-users] Cannot open root device
From: Hsing-Foo Wang <hsing-foo.wang@xxxxxxxxxxxxxxxx>
Date: Sun, 05 Jun 2005 09:08:37 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 05 Jun 2005 07:08:11 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1117954775.7271.6.camel@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <42A29DB8.5080505@xxxxxxxxxxxxxxxx> <42A29FE2.2020501@xxxxxxxxxxxxxxxx> <1117954775.7271.6.camel@xxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
Hi Lyndsay, thanks for the quick reply.

Lyndsay Roger wrote:
On Sun, 2005-06-05 at 08:46 +0200, Hsing-Foo Wang wrote:

#disk = [ 'file:/etc/xen/ttyfs,md1,w' ]
disk = [ 'phy:/dev/loop0,md1,w' ]

Sorry, The above is just the other way around. I folowed instrctions in the mailing archive regarding testing the loop0 approach. No luck.
The values of 'file:...' are correct tho.

disk = [ 'file:/etc/xen/ttyfs,md1,w' ]

This line tells the guest domain to map the ttyfs file to device md1.
Does ttylinux have support for raid devices like md1?

Good question, I do not know atm. I will google for it.

Did you try and change this and the root device line to use hda1?

Yes I did, since I have scsi I tried sda1 too but no luck
Then again I am a bit confuse on what to use with 'file:....'
Do I point to the mountpoint or the ttylinyx-xen image file? Again tried both, but no luck.

Also, the line 'root = "/dev/md1"' should this be point to the real host device which in my case is /dev/md1?

Very confused, been trying this for ages now....


See if that works


Xen-users mailing list

Xen-users mailing list