This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] unstable binaries

On Fri, Mar 04, 2005 at 02:29:38PM +0100, nils toedtmann wrote:
> On Thu, Mar 03, 2005 at 02:38:14PM -0000, Ian Pratt wrote:
> > > wget oopses sometimes, never seen that before:
> > > 
> > >     wget http://...
> > >     25% [======>                    ] 1,028,840     55.08K/s  
> > >   ETA 06:31
> > >     wget: retr.c:293: calc_rate: Assertion `msecs >= 0' failed.
> > >     Aborted
> > 
> > It sound like time may be screwed on your system, which is rather
> > surprising.

Ok, after lots of compiling, rebooting & testing, i got this picture:

The error "wget: retr.c:293: calc_rate: Assertion `msecs >= 0' failed."
is still present with xen-2.0-testing ("ChangeSet@xxxxxx, 2005-03-04 
00:57:22"), but now i have to trigger them by higher load. I was not
able to reproduce it on a vanilla kernel with same config (besides 
ARCH specific options).

> > What kind of CPU do you have?

  $ cat /proc/cpuinfo
  processor       : 0
  vendor_id       : AuthenticAMD
  cpu family      : 6
  model           : 4
  model name      : AMD Athlon(tm) Processor

> > Does wget still fail if you're in a text mode? (I think we really need
> > to rule out any interaction with AGP or X). 

Yes: could reproduce it on tty1 without any X running. Some kernel config:

  # CONFIG_MODULES is not set
  # CONFIG_AGP is not set

> > Please can you try running LTP on your system. Does it pass all the time
> > tests?

No. I ran the default testset (ltp-full-20050207) on xen0-2.0.4 and
repeated the failed tests on different kernels (all 2.6.10): 
1.770_FC3 (fedora errata kernel), vanilla, xen0-2.0-testing (2.3.), 
xen0-2.0-testing (4.3.). Except the FC3 kernel, they all had the same 
config (except options not present due to ARCH). The test "fcntl23" 
failed on all kernels, so it probably a fedora issue. The tests 
"ioperm02", "iopl02" and "nanosleep02" failed on all xen-kernels,
and only on them. This is the output for "nanosleep02":

  nanosleep02    1  FAIL  :  Remaining sleep time 4010000 usec doesn't match 
with the expected 3999236 usec time
  nanosleep02    1  FAIL  :  child process exited abnormally
  incrementing stop
  duration=1 termination_type=exited termination_id=1 corefile=no
  cutime=0 cstime=0

All other default tests passed on all kernels, including 

> I'll try to check that on monday, is that ok?

So here i am. I hope it was worth it ...


there is no sig.

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list