[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Kdump doesn't work when running with xen on newer hardware

On 04.02.20 15:07, Dietmar Hahn wrote:
Am Freitag, 31. Januar 2020, 22:59:19 CET schrieb Igor Druzhinin:
On 30/01/2020 13:03, Dietmar Hahn wrote:

we use SLES12 with kernel-default-4.12.14-95.45.1.x86_64 and

The dump kernel doesn't start after "echo c > /proc/sysrq_trigger".
Last messages on console are:
[  385.717532] Kernel panic - not syncing: Fatal exception
[  385.734565] Kernel Offset: disabled
(XEN) Hardware Dom0 crashed: Executing kexec image on cpu58
(XEN) Shot down all CPUs

After a short time a reboot is initiated.
Without xen the kdump works.

We see this behaviour only on newer hardware, for example a server with
Intel(R) Xeon(R) Gold 6242 CPU @ 2.80GHz

I built the fresh released xen-4.13 myself and tried it but this doesn't help.

I tried x2apic=off on the xen side and nox2apic on the linux side but no 

Starting from Xen 4.12 we keep IOMMU enabled during kexec transition
which resolved the problem you're describing. But you also need to make
sure IOMMU is enabled in your kexec kernel (which I think is now the
default for most distros). You can still try to workaround the issue
you're seeing on 4.11 by using "iommu=dom0-passthough" Xen option.

I added "iommu=dom0-passthrough" to the xen-4.11 command line but no success.
Further I added earlyprintk=... to the the kdump kernel and I could see the
dump kernel started and only one message from extract_kernel()
was printed. Then the reboot followed.

Which message?

Any chance you can build the kdump kernel with CONFIG_X86_VERBOSE_BOOTUP


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.