[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 5/5] x86: Reorganise and rename debug register fields in struct vcpu

> From: Andrew Cooper [mailto:andrew.cooper3@xxxxxxxxxx]
> Sent: Monday, October 15, 2018 6:36 PM
> Reusing debugreg[5] for the PV emulated IO breakpoint information is
> confusing
> to read.  Instead, introduce a dr7_emul field in pv_vcpu for the pupose.
> With the PV emulation out of the way, debugreg[4,5] are entirely unused
> and
> don't need to be stored.
> Rename debugreg[0..3] to dr[0..3] to reduce code volume, but keep them
> as an
> array because their behaviour is identical and this helps simplfy some of
> the
> PV handling.  Introduce dr6 and dr7 fields to replace debugreg[6,7] which
> removes the storage for debugreg[4,5].
> In arch_get_info_guest(), handle the merging of emulated dr7 state
> alongside
> all other dr handling, rather than much later.
> Signed-off-by: Andrew Cooper <andrew.cooper3@xxxxxxxxxx>

Reviewed-by: Kevin Tian <kevin.tian@xxxxxxxxx>
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.