[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Xen EFI] Impossible to limit the dom0 memory

# About the kernel crash

Did you read the above?

I just wanted to say that I have solved the kernel panic crash that I had before, when you explained "Xen doesn't crash at all. It's the Dom0 kernel which panics".

Just for information the crash happens if I put the "console=com1" to the kernel command line.

kernel=vmlinuz root=/dev/md2 ro rootdelay=10 noquiet nosplash earlyprintk=xen console=com1

And this, I understand, is not linked to Xen.

# About the Xen Dom0 crash

This tells us (together with the page fault error code) that the
Dom0 kernel tried to provide memory as kernel stack which
can't be written. This may be a Dom0 kernel stack overflow,
but there may also be other reasons. At this point I can't
exclude there being some root cause in Xen, but the issue
needs to be investigated from the Dom0 kernel side.

I have tested with the version 4.9 and 4.14 of the kernel from Debian and the crash occurs when there is the option "dom0_mem=1G,max:1G".


Do you want that I test something else ?



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.