[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v4 10/11] dma: rename dma_*_writecombine() to dma_*_wc()

* Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:

> > There's a catch-22 issue here either way, for instance this rename patch 
> > has 
> > been being baked for probably 2 releases already but the difficulty has 
> > been 
> > trying to find the appropriate time to merge it without conflict.
> > 
> > If you do it in the beginning of the merge window, you have to ask yourself 
> > in 
> > what tree it will be done. Since subsystems are topic specific that means 
> > that 
> > subsystem will end up having a conflict at the end of the merge window.
> Yes it's a special case.  I think the best way of handling such things is to 
> get 
> them in to Linus either right at the end of the merge window or the day after 
> he 
> releases -rc1.  This is when most people's trees are mostly empty.

Yes, that was the plan last time around as well - but the end of the merge 
is when we have the least maintainer bandwidth as well ...

Anyway, I applied most of the patches (sans the rename), so the rename patch 
should be a lot simpler to execute at the right moment this time around.



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.