[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Test report for xen-unstable and qemu-xen

On 22/05/13 15:48, Fabio Fantoni wrote:
Wheezy 64 bit with kernel from package linux-image-3.2.0-4-amd64 version 3.2.41-2+deb7u2, package blktap-dkms and all dependency packages for xen, spice and usb redirection. Seabios 1.7.2-2 and latest spice and usbredir compiled from debian unstable sources.
loop max_loop=64
git clone git://xenbits.xen.org/xen.git (in this build commit is 3a4a1d297766c0617129fb9eeef164293926ae89)
Added some patches:
- tools-configure-qemu-for-spice-and-usbredir
- libxl-Add-spice-vdagent-support-for-upstream-qemu
- tools-firmware-seabios-packaged
- tools: Improve make deb
- vgabios-stdvga.bin custom build from Frediano
- tools-fix-xendomain-restore-xl
- qemu-xen change for support other resolutions:
hw/vga.c: # from Frediano patch
    - if ((val <= VBE_DISPI_MAX_XRES) && ((val & 7) == 0)) {
    + if ((val <= VBE_DISPI_MAX_XRES) && ((val & 1) == 0)) {
- fix for one qxl bug: # from anthony perard
--- a/hw/qxl.c
+++ b/hw/qxl.c
@@ -390,6 +390,7 @@ static void init_qxl_ram(PCIQXLDevice *d)
     d->ram->int_pending = cpu_to_le32(0);
     d->ram->int_mask    = cpu_to_le32(0);
     d->ram->update_surface = 0;
+    d->ram->monitors_config = 0;
./configure --prefix=/usr
make debball

Issues solved from my previous test build report:
- restore with xl on xendomain not work
  solved with patch "xl problems with xendomains":

Thank you for testing this. In general it would be better to respond to the threads pertaining to individual issues to update things, and make a new thread for new issues. In this case, it would be helpful if you would instead respond to this thread saying, "Tested-by: Fabio Fantoni <...>"


Recent regression:
- on W7 pro 64 bit domU error in the begin of qemu log, while domU seem to work: xc: error: linux_gnttab_set_max_grants: ioctl SET_MAX_GRANTS failed (22 = Invalid argument): Internal error
xen be: qdisk-832: xc_gnttab_set_max_grants failed: Invalid argument

I don't quite understand: Are you saying that you see this error message, but the guest still works as far as you can tell?


Old issue:
- Network is not working after restore on Windows domU with qemu-xen and gplpv
  Workaround: fixed mac address
- Unable to get QXL vga working correctly
Status: one fix available and work in progress about the remaining problem (for now I made quick tests without success)

These issues are actively being worked on; there's no need to comment on them in particular. If you think the issue may have been forgotten about, the best thing to do is to respond to one of the old threads and ask if there has been any progress.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.