[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Test report for xen-unstable and qemu-xen

Wheezy 64 bit with kernel from package linux-image-3.2.0-4-amd64 version 3.2.41-2+deb7u2, package blktap-dkms and all dependency packages for xen, spice and usb redirection. Seabios 1.7.2-2 and latest spice and usbredir compiled from debian unstable sources.
loop max_loop=64
git clone git://xenbits.xen.org/xen.git (in this build commit is 3a4a1d297766c0617129fb9eeef164293926ae89)
Added some patches:
- tools-configure-qemu-for-spice-and-usbredir
- libxl-Add-spice-vdagent-support-for-upstream-qemu
- tools-firmware-seabios-packaged
- tools: Improve make deb
- vgabios-stdvga.bin custom build from Frediano
- tools-fix-xendomain-restore-xl
- qemu-xen change for support other resolutions:
hw/vga.c: # from Frediano patch
    - if ((val <= VBE_DISPI_MAX_XRES) && ((val & 7) == 0)) {
    + if ((val <= VBE_DISPI_MAX_XRES) && ((val & 1) == 0)) {
- fix for one qxl bug: # from anthony perard
--- a/hw/qxl.c
+++ b/hw/qxl.c
@@ -390,6 +390,7 @@ static void init_qxl_ram(PCIQXLDevice *d)
     d->ram->int_pending = cpu_to_le32(0);
     d->ram->int_mask    = cpu_to_le32(0);
     d->ram->update_surface = 0;
+    d->ram->monitors_config = 0;
./configure --prefix=/usr
make debball

Issues solved from my previous test build report:
- restore with xl on xendomain not work
  solved with patch "xl problems with xendomains":

Recent regression:
- on W7 pro 64 bit domU error in the begin of qemu log, while domU seem to work: xc: error: linux_gnttab_set_max_grants: ioctl SET_MAX_GRANTS failed (22 = Invalid argument): Internal error
xen be: qdisk-832: xc_gnttab_set_max_grants failed: Invalid argument

Old issue:
- Network is not working after restore on Windows domU with qemu-xen and gplpv
  Workaround: fixed mac address
- Unable to get QXL vga working correctly
Status: one fix available and work in progress about the remaining problem (for now I made quick tests without success)
- nested hvm probably bugged: started test it on windows 7 pro 64 domU on qemu-xen, xpmode crash on install without show error, no error on logs and havdetection works
- Starting xendomain with "xl create" show some debug options:
  Starting auto Xen domains: W7.cfgxc: info: VIRTUAL MEMORY ARRANGEMENT:
  Loader:        0000000000100000->000000000019eb68
  Modules:       0000000000000000->0000000000000000
  TOTAL:         0000000000000000->000000007f000000
  ENTRY ADDRESS: 0000000000100000
  4KB PAGES: 0x0000000000000200
  2MB PAGES: 0x00000000000003f7
  1GB PAGES: 0x0000000000000000
I think it is would be better hiding them here

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.