[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Debootstrapping a rootfs for Xen on FastModels A15

On Tue, 2 Apr 2013, Sander Bogaert wrote:
> I did however try the branches you linked but without much progress.
> Using the xen and kernel branches you linked together with this config
> ( http://xenbits.xen.org/people/sstabellini/config where I selected
> the defaults for newer kernel options ) Xen crashes. I attached a log;
> log.txt. Isn't this the exact same setup as you are using?

I am attaching the kernel config I am using with that branch.
However I tried the one linked above, using the default for all the
newer kernel options, and I can still boot Dom0 to a bash prompt :-S
For the sake of completeness I am also going to attach my DTS (that is
SMP ready).

> About the 'regular' branches: The problem I'm having with a
> non-ramdisk kernel and my debootstrapped rootfs I'm also facing
> without Xen on the FastModel simulator. I know this isn't really the
> place to ask but if you have any idea on how to fix it I would really,
> really appreciate it! I've been stuck for quite some time on it and I
> know others have it working. All the information from my initial mail
> is still relevant.
> <NUL>[   12.340651] VFS: Cannot open root device "mmcblk0" or
> unknown-block(0,0): error -6
> [   12.340714] Please append a correct "root=" boot option; here are
> the available partitions:
> [   12.340805] Kernel panic - not syncing: VFS: Unable to mount root
> fs on unknown-block(0,0)
> [   12.340947] [<c000d3a8>] (unwind_backtrace+0x0/0xe0) from
> [<c02ac5a0>] (panic+0x70/0x1c0)
> ....
> I included logs from this kernel and my rootfs booting on the model (
> log_linux.txt ) and with Xen ( log_xen.txt ). I also tried with having
> root mmcblk0p0 and some other things. I just debootstrapped a rootfs (
> wheezy ) the way I described so I'd think it should be mmcblk0 or
> mmcblk0p0.
> I really hope someone could help with getting this setup working,
> either the 'regular' one or the uncommited branches. I've been at this
> for days and really need a working setup.

It looks like an interrupt issue: Linux doesn't receive any interrupts
from the MMC controller. But I don't know what the exact cause of the
issue could be. I would start investigating by adding some printk's to

Attachment: config
Description: Text document

Attachment: vexpress-v2p-ca15-tc1.dts
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.