[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Debootstrapping a rootfs for Xen on FastModels A15

On 1 April 2013 13:51, Stefano Stabellini
<stefano.stabellini@xxxxxxxxxxxxx> wrote:
> On Sun, 31 Mar 2013, Sander Bogaert wrote:
>> Hi,
>> I've tried several different approaches to debootstrap a working
>> rootfs for with a Cortex A15 model ( FastModels ) and Xen but still
>> face some issues.
>> Some information on my setup.
>> For a Dom0 kernel I'm using the latest version from
>> git://github.com/torvalds/linux.git, I attached my config as it might
>> be of some use for others. I'm using the latest Xen unstable branch
>> git://xenbits.xen.org/xen.git and my device tree comes from:
>> git://xenbits.xen.org/people/sstabellini/device-trees.git .
>> These are my xen and kernel arguments:
>> bootargs = "dom0_mem=128M dom0_max_vcpus=1 console=com1,vga";
>>  xen,dom0-bootargs = "earlyprintk=xenboot console=ttyAMA0
>> root=/dev/mmcblk0 init=/bin/bash rw ip=dhcp";
>> This is how I launch the model ( where the variables of course contain
>> the right paths ):
>> ./model_shell ../resources/Cortex-A15x1/cadi_system_Linux-Release-GCC-4.4.so
>> $1 -C motherboard.flashloader0.fname=$2 -C
>> motherboard.smsc_91c111.enabled=1 -C
>> motherboard.hostbridge.userNetworking=1 -C
>> motherboard.pl011_uart0.out_file=./log.txt -C
>> motherboard.mmc.p_mmc_file="$3"
>> To get a basic filesystem I:
>> - created a empty file ( with fallocate or dd )
>> - formated it ext4
>> - mounted the file and used HOSTNAME=armhf sudo debootstrap --foreign
>> --arch armhf wheezy $path
>> - did the some configuration and the second stage debootstrapping
>> The problem now is Xen hangs on/after booting dom0, I included a log (
>> log.txt ). This filesystem boots fine with the same kernel, without
>> Xen on the same FastModel model.
>> My question: did I miss something in the debootstrapping? Are there
>> some steps I don't know of? Does anyway have an idea on what goes
>> wrong ( see log.txt )?
> I don't see any mistakes in your setup. Unless you are running an
> outdated version of the FastModel (they were known to have a broken
> virt_timer implementation), my guess is that you are seeing an
> issue that we actually have already solved.

I'm using version 8, downloaded last week. Model_shell is version 8.0.16.

> At the moment Ian is on vacation (the Xen on ARM committer), as a
> consequence we have several outstanding patches, many of which are
> actually bug fixes. Maybe the very latest trees would solve your issue.
> Could you please try:
> git://xenbits.xen.org/people/sstabellini/linux-pvhvm.git 
> 3.9-rc3-smp-dom0-hack-2
> git://xenbits.xen.org/people/sstabellini/xen-unstable.git guest-smp-3

I discovered that the kernel I was trying this with before is one I
compiled with a ramdisk, the problems in my initial e-mail could be
related to that ( I had many kernel images and mixed them up ).

I did however try the branches you linked but without much progress.
Using the xen and kernel branches you linked together with this config
( http://xenbits.xen.org/people/sstabellini/config where I selected
the defaults for newer kernel options ) Xen crashes. I attached a log;
log.txt. Isn't this the exact same setup as you are using?

About the 'regular' branches: The problem I'm having with a
non-ramdisk kernel and my debootstrapped rootfs I'm also facing
without Xen on the FastModel simulator. I know this isn't really the
place to ask but if you have any idea on how to fix it I would really,
really appreciate it! I've been stuck for quite some time on it and I
know others have it working. All the information from my initial mail
is still relevant.

<NUL>[   12.340651] VFS: Cannot open root device "mmcblk0" or
unknown-block(0,0): error -6
[   12.340714] Please append a correct "root=" boot option; here are
the available partitions:
[   12.340805] Kernel panic - not syncing: VFS: Unable to mount root
fs on unknown-block(0,0)
[   12.340947] [<c000d3a8>] (unwind_backtrace+0x0/0xe0) from
[<c02ac5a0>] (panic+0x70/0x1c0)

I included logs from this kernel and my rootfs booting on the model (
log_linux.txt ) and with Xen ( log_xen.txt ). I also tried with having
root mmcblk0p0 and some other things. I just debootstrapped a rootfs (
wheezy ) the way I described so I'd think it should be mmcblk0 or

I really hope someone could help with getting this setup working,
either the 'regular' one or the uncommited branches. I've been at this
for days and really need a working setup.

Attachment: log_linux.txt
Description: Text document

Attachment: log_xen.txt
Description: Text document

Attachment: log.txt
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.