[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] libxl.c ERROR during compiling Xen 4.2-Unstable revision 25374

Hey Ian thanks for the reply back. Well i have done some more compiling and messing with and
this is what i found so far:

This time i did as you said, i piped the compile output to a file using the tee command.

Â---------------------------- ---------------------------- ---------------------------- ----------------------------
A.) I cloned a fresh copy of xen-unstable.hg rev-25376 (5/22/2012) and ran:

sudo make -j5 xen ÂÂ --> This compiled fine and didn't see any errors
sudo make -j5 tools --> THIS is where all of the errors happen and fail to compile

Â---------------------------- ---------------------------- ---------------------------- ----------------------------
B.) This time i installed the SDL devel package as you suggested and cloned another fresh copy of
ÂÂÂÂÂ xen-unstable.hg rev-25376

sudo apt-get install libsdl1.2-dev
sudo make -j5 xen ÂÂ --> Again, this compiled fine and saw no errors
sudo make -j5 tools --> This time i do not get that error about the libSDL BUT i still get other errors
Â---------------------------- ---------------------------- ---------------------------- ----------------------------
I have saved the above compile trials to 4 files as the following:

Compiled BEFORE installing libsdl1.2-dev
A - make_xen.log
A - make_tools.log

Compiled AFTER installing libsdl1.2-dev
B - make_xen.log
B - make_tools.log

ALSO, since i didn't want to attach so many large files in a text format, i put all 4 files in a TAR.GZ file
and attached that instead.
--------------------------- ---------------------------- ---------------------------- ----------------------------

So, hopefully this will be helpful to you or to some else in determining why, in this case,
Xen 4.2-unstable REV-25376 is not wanting to compile anymore .... :)

On Sun, 2012-05-20 at 17:43 +0100, cyberhawk001@xxxxxxxxx wrote:
 I have had Xen 4.2-Unstable compiled a week or so ago and it all went
fine and running, but i forget what revision i compiled now.

When i ran the xl create /etc/xen/win7.cfg to create a VM, i got an
error about libxl and running "sudo xl list" shows the newly created
VM, SO i just ignored that error for now. That error message was:

libxl: error: libxl.c:3117:libxl_sched_credit_domain_set: Cpu weight
out of range, valid values are within range from 1 to 65535
This is a harmless warning and is on our list to fix for 4.2

---------------------------------- ----------------------------------

SO, I noticed on the xen-unstable.hg tree that there have been a lot
of updates to the libxl lately SO just out of curiosity, i wanted to
get the latest revision 25374 of xen-unstable as of today 5/20/2012,
and compile it. BUT, i cannot compile Xen anymore as the compile stops
with warnings and error messages. 

Upon scrolling up in the terminal window, i noticed these warning or
error messages:
Thanks, it can be useful for us to see the full context, in which case
using something like tee(1) to collect the full log and attaching it can
be useful.

node-select.c:57:6: warning: function declaration isnât a prototype [-Wstrict-prototypes]
node-select.c: In function âvchan_wrâ:
node-select.c:60:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
node-select.c: At top level:
node-select.c:71:6: warning: function declaration isnât a prototype [-Wstrict-prototypes]
node-select.c: In function âstdout_wrâ:
node-select.c:74:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
These are genuine warnings but aren't causing build failures (I presume
no -Werror in that subdir).

The error log from compiling the libSDL test is: 
/tmp/qemu-conf--3330-.c:1:17: fatal error: SDL.h: No such file or directory
This means you are missing the SDL development package. I'm not sure if
this is optional or mandatory, nor whether this message is fatal without
more context from the build logs.

../xen-unstable.hg/tools/qemu-xen-traditional-dir/hw/eepro100.c:1232:5: warning: âvalâ may be used uninitialized in this function [-Wuninitialized]

I also get like a dozen warnings about this:
../tools/xenstore/compat/xs.h:1:2: warning: #warning xs.h is
deprecated use xenstore.h instead [-Wcpp]
These are currently to be expected and are harmless.

AND finally the compilations stops with these messages:
libxl.c: In function âlibxl_primary_console_execâ:
libxl.c:1233:9: error: case value â4294967295â not in enumerated type
âlibxl_domain_typeâ [-Werror=switch]
This one is known and a fix is in progress. It's most likely this one
which is causing the actual build error.

This slipped through our testing net due to various compiler versions
being cleverer/stupider than others and so trigger more or less
warnings, this one happens only with a more modern gcc than what our
test system uses.


Attachment: Xen4.2_rev25376_compile_log.tar.gz
Description: GNU Zip compressed data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.