[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] libxl.c ERROR during compiling Xen 4.2-Unstable revision 25374

 I have had Xen 4.2-Unstable compiled a week or so ago and it all went fine and running, but i forget what revision i compiled now.

When i ran the xl create /etc/xen/win7.cfg to create a VM, i got an error about libxl and running "sudo xl list" shows the newly created VM, SO i just ignored that error for now. That error message was:

libxl: error: libxl.c:3117:libxl_sched_credit_domain_set: Cpu weight out of range, valid values are within range from 1 to 65535

---------------------------------- ---------------------------------- ----------------------------------

SO, I noticed on the xen-unstable.hg tree that there have been a lot of updates to the libxl lately SO just out of curiosity, i wanted to get the latest revision 25374 of xen-unstable as of today 5/20/2012, and compile it. BUT, i cannot compile Xen anymore as the compile stops with warnings and error messages.

Upon scrolling up in the terminal window, i noticed these warning or error messages:

node-select.c:57:6: warning: function declaration isn’t a prototype [-Wstrict-prototypes]
node-select.c: In function ‘vchan_wr’:
node-select.c:60:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]
node-select.c: At top level:
node-select.c:71:6: warning: function declaration isn’t a prototype [-Wstrict-prototypes]
node-select.c: In function ‘stdout_wr’:
node-select.c:74:2: warning: ISO C90 forbids mixed declarations and code [-Wdeclaration-after-statement]

The error log from compiling the libSDL test is:
/tmp/qemu-conf--3330-.c:1:17: fatal error: SDL.h: No such file or directory

../xen-unstable.hg/tools/qemu-xen-traditional-dir/hw/eepro100.c:1232:5: warning: ‘val’ may be used uninitialized in this function [-Wuninitialized]

I also get like a dozen warnings about this:
../tools/xenstore/compat/xs.h:1:2: warning: #warning xs.h is deprecated use xenstore.h instead [-Wcpp]

AND finally the compilations stops with these messages:
libxl.c: In function ‘libxl_primary_console_exec’:
libxl.c:1233:9: error: case value ‘4294967295’ not in enumerated type ‘libxl_domain_type’ [-Werror=switch]

cc1: all warnings being treated as errors
make[3]: *** [libxl.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/home/xyber/Desktop/KERNEL_BUILD/Xen/xen-unstable.hg/tools/libxl'
make[2]: *** [subdir-install-libxl] Error 2
make[2]: Leaving directory `/home/xyber/Desktop/KERNEL_BUILD/Xen/xen-unstable.hg/tools'
make[1]: *** [subdirs-install] Error 2
make[1]: Leaving directory `/home/xyber/Desktop/KERNEL_BUILD/Xen/xen-unstable.hg/tools'
make: *** [install-tools] Error 2

---------------------------------- ---------------------------------- ----------------------------------

All of these messages appear at different times during compile, but these where the ones i found thru a quick glance at the terminal window output. I have also tried to compile the latest Xen 4.2 THREE different times now, and in all cases it seems to end with a similar error about libxl.c.

Each time i tried to compile, i booted into non-Xen kernel, ran "sudo make uninstall" of my current Xen 4.2-unstable and ran "sudo dpkg -r xen-upstream-4.2-unstable", AND twice now i cloned a fresh copy of the xen-unstable.hg before compile.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.