[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen4.1.0 and Fedora15 Block device bug?

I have a PXE-installer environment that i use for the installation of the Ganeti instances. For both versions of Fedora, i've used the kernel/initrd provided in their images/pxeboot/ folder as the pxe target. They both catch and load anaconda, but it errors out at the storage device configuration of the install process, saying it can't find any usable storage devices. 

I've just finished testing it on a vanilla centos 5.6 w/ virtualization package, which runs xen 3.1; doing both cdrom/iso and pxe boot installs. the same issue. I used lv-based storage for virtual block devices in both contexts, and although fedora14 would complain about an un-initialized drive, it would initialize the device and treat it as an ide block device. Fedora 15 (or the included version of disk druid) doesn't seem to know how to initialize a block device.

To examine disk initialization may be a red herring, however, as the issue persists even after otherwise initializing the disk. (using fdisk on the logvol or installing 14/centos then reinstalling w/ 15) 

I've also tried to use raw and vmdk file formats as file-based block devices. same issue. 

However, it works perfectly using virtualbox or qemu+kvm. 

I know that xen dom0 support, though intended for a return in 15 was pushed back to the next release, but i've not read anything regarding a xen domU support regression; Though in HVM I would expect that to be a non-issue. 

On Thu, Jun 30, 2011 at 6:05 PM, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> wrote:
On Thu, Jun 30, 2011 at 02:45:42PM -0400, Travis wrote:
> Hi guys,
> I'm an administrator for a small cluster running ganeti2.3.1/xen4.1.0/drbd83
> on centos5.6, with predominantly fedora14 instances. We've been running the
> fedora 14 images pretty well, not many issues. However, I've noticed that in
> an attempt to install fedora 15, the virtualized block devices are
> unrecognized by anaconda. has anyone else seen this or is this a known

Uh, I hadn't tried to install it. How did you install Fedora Core 14 in the past?

"Eating and sleeping are the only activities that should be allowed
to interrupt a man's enjoyment of his cigar." - Mark Twain
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.