[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] dom0 system functions impaired after creating domU on xen4.1 running 2.6.32-jeremy

On Wed, Jun 15, 2011 at 01:08:25PM +0200, Andreas Olsowski wrote:
> I decided to migrate from my old Xen platform (xen4.0 with
> 2.6.31-pvops dom0 and 2.6.32 guests) to my new one (xen4.1 with
> 2.6.32-jeremy dom0 and 2.6.39 guests).
> Everything was going fine when, without indication of any problems,
> "xm create /etc/xen/domains/xy.sxp -c" didnt produce output anymore
> and the guest didnt start. (no output = no kernel booting, no error
> message, nothing, zip, nada)

And you updated the toolstack?

You can add 'earlyprintk=xenboot debug loglevel=10 initcall_debug' in
the Linux command line ('extra') to see where it choked.

> So i went to cancel the process, destroy the domain, retry with xm,
> try a different guest, but to no avail. (I tried xl too at that
> point)
> Just to se whats going on i ran "ps auxw"  ... it hung itself after
> listing some processes.

Uhh.. that is most bizzare.
> So in addition to not beeing able to create new guests i couldnt
> even list my processes.
> I live migrated all the guests to another host and went on to "init
> 6" the affected server.
> At the stage where is suppose all remaining processes received the
> signal to stop, the terminal i initially ran "xm create" on popped
> out 2 lines of text i sadly neglected to copy (i guess some generic
> error creating domain, or creation cancelled, sth like that)
> Additionally "ps auxw" started working again and after a short while
> the box rebooted as expected.
> I had noticed this behavior earlier, like 2 weeks ago, but didnt
> think much of it, since i was working on the system configuration
> and had to reboot the server anyway.
> Does anybody have a clue what could lead to this behavior?

Hm, perhaps your disk is not getting the interrupts the bash
shell is blocking on a read? Were there any error messages reported
by 'dmesg'?
> The systems are pretty much what i would expect most xen hosts to
> be, some linux (debian 6.0 in my case), a current version of Xen and
> a current jeremy pvops dom0 kernel. (kernel is now and was
> an earlier version when i first encountered the problem)
> Should i maybe restrain myself from using xm to create guests or
> even from using it altogether? (xl has no live migration and cant xl
> new ... xl start)

I've been using them. Not really sure what is happening in your case.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.