[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 13/14] libxl: disks: allow specification of "backendtype=phy|tap|qdisk"

Ian Campbell writes ("Re: [Xen-devel] [PATCH 13/14] libxl: disks: allow 
specification of "backendtype=phy|tap|qdisk""):
> On Thu, 2011-05-12 at 15:36 +0100, Ian Jackson wrote:
> > +/* Sets ->backend based on the string value.  This ought to be an enum. */
> Is this an old comment? Backend is a libxl_disk_backend, which _is_ an
> enum.

What I mean, now, is that the IDL should provide a table of these
strings, and there should be a standard conversion function, rather
than this open-coded list of strcmps.  I will update the comments.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.