[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] USB disk corruption on Xen 4.1.0 & Linux

On 31/05/2011 15:54, Konrad Rzeszutek Wilk wrote:
> Ok.. Had you tried my #devel/next-2.6.38 branch in the past?

Yes I tried one of your devel kernels in the past, but switched back to stock 
linux when I realised that Dom0 functionality was now in that. I'm willing to 
give a devel kernel a go if you think it would help.

> So this is from dom0 kernel, right?

The corruption occurs in the Dom0 kernel.

> What is the filesystem on the USB disk?

The filesystem on the USB disk is ext2. It's a slightly funny format because 
while the memory stick is a 2GB memory stick, it's partitioned and formatted as 
a 64MB memory stick. I've done an md5sum on the raw /dev/sdX device under a 
system that works and under a system that's faulty and I get different results, 
so I suspect the fault's below the file system.

> <sigh>Please provide serial log or dmesg output.

dmesg output is attached, but it doesn't show anything that I can see (I boot 
off a CD and then mount the USB memory stick - the fsck errors at the end)

On 01/06/2011 09:53, Ian Pratt wrote:
> Does the issue go away if you limit the total amount of memory visible to xen 
> to 4GB? (mem=4096M on the xen command line)
> If so, I suspect this is a swiotlb or latent UHCI driver issue. The easiest 
> way of working around it is just to ensure all > dom0 memory gets allocated 
> below 4GB, but it would be good to investigate properly.

Yes! I put mem=4096M on the xen command line as asked and everything starts 
working as it should yea!


Attachment: dmesg
Description: Binary data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.