[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen-unstable + pvops-kernel doesn't boot on my machine, ibm x3550M2

On 05/27/2010 09:10 AM, Min Lee wrote:
> Hi, Jeremy.
> I'm attaching full boot log for both working/non-working case.
> The working case is xen-unstable+linux2.6.18.8 and it boots up, at least.
> Nonworking case is pvops kernel native.

That just looks like your initrd isn't set up properly.  How did you
generate it?  Do you have all the right dm config options to make lvm work?


> it might be some stupid mistake, but I've tried many configurations,
> but still it doesn't boot..so I hope I can hear from you.
> Thanks!
> Min
> On 5/26/2010 5:09 PM, Jeremy Fitzhardinge wrote:
>> On 05/26/2010 10:20 AM, Min Lee wrote:
>>> Hello.
>>> I've tried Xen-unstable + Jeremy's pvops kernel on ibm x3550M2 server
>>> machine, but it fails to mount root fs.
>>> I'm using ibm x3550M2 server with broadcom NetXtreme II network card,
>>> and ibm RAID. (64bit)
>>> Even running pvops-kernel without xen fails, too, and I could see this
>>> booting message.
>>> pci 0000:01:00.0: BAR 6: no parent found for of device
>>> [0xffff0000-ffffffff]
>> Can you post the full boot log?  And the boot log of a kernel which does
>> succeed?  If the kernel doesn't boot native you need to sort that out
>> before trying to debug the Xen case.
>>      J
>>> Module for the raid (megaraid_sas.ko) is in initrd file.
>>> I've also tried xen-unstable + 2.6.18-xen and it boots, but it doesn't
>>> detect my network card.
>>> it seems like it fails to allocate apic I/O resources.
>>> Anybody who's running xen-unstable on similar configuration ??
>>> Thank you for any comments or help.
>>> Min
>>> _______________________________________________
>>> Xen-devel mailing list
>>> Xen-devel@xxxxxxxxxxxxxxxxxxx
>>> http://lists.xensource.com/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.