[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Strange error in domU after dom0 update


Thanks for your hint - but it does not change anything for my problem switching this on or off.

Spend some more time on investigations: My current assumption is, that there is some problem with the network driver (which would explain the iSCSI timeout errors).

My test-setup: xen-unstable, dom0 with pvops kernel and one domU running Debian Lenny (based on 2.6.26). In the domU a 'nuttcp -S' is running.
Output from a dom0 shell:
# nuttcp -T 10 -t ; date ; nuttcp -T 10 -r ; date
 1344.3750 MB /  10.06 sec = 1120.9618 Mbps 1 %TX 17 %RX
Fri Oct 23 13:00:40 CEST 2009
*** transfer interrupted ***
Fri Oct 23 13:02:52 CEST 2009

The first run transfers data from the dom0 to the domU - which works. The other way (transferring data from domU to dom0) never stops (I pressed Ctrl-C after about two minutes).

[It's getting ever more curious: when I run the '-r' version with a 'strace' it runs fine - with a speed about 400Mbps. So when I have a closer look at the problem, the problem vanishes - looks a bit like Schrödinger's cat ;-).]

I run another test with sftp transferring data from domU to dom0 - which gives me (when I'm lucky) about 20kB/s - with a lot 'stalled' in between.

Were there some changes in the backend network device which could explain this behavior (e.g. rate limiting, additional features, ...)?

Kind regards - Andreas

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.