[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Possible bug with pass-through hot-plug?

On Sun, Oct 11, 2009 at 11:57:00AM +0200, Tom Rotenberg wrote:
> Simon,
> Well, just tried it, according to what u requested, and it still doesn't work.
> Here are the lines from the qemu log:
> ...
> platform_fixed_ioport: changed ro/rw state of ROM memory area. now is rw 
> state.
> platform_fixed_ioport: changed ro/rw state of ROM memory area. now is ro 
> state.
> dm-command: hot insert pass-through pci dev
> insert_to_pci_devfn: bdf_slt="0000:00:1b.0@e8"
> insert_to_pci_devfn: devfn=0xe8 -> slot=0x1d, func=0x0
> register_real_device: Assigning real physical device 00:1b.0 ...
> pt_iomul_init: Error: pt_iomul_init can't open file
> /dev/xen/pci_iomul: No such file or directory: 0x0:0x1b.0x0
> pt_register_regions: IO region registered (size=0x00004000 
> base_addr=0xfc220004)
> register_real_device: Real physical device 00:1b.0 registered successfuly!
> IRQ type = INTx
> generate a sci for PHP.
> deassert due to disable GPE bit.
> pt_pci_write_config: Warning: Guest attempt to set address to unused
> Base Address Register. [00:1d.0][Offset:30h][Length:4]
> dm-command: hot remove pass-through pci dev
> ...
> I performed the following sequence:
> ...
> xm create
> <waited untill Windows booted>
> xm pci-attach hvm 00:1b.0@1d
> <I saw that it worked>
> xm pci-detach hvm 00:1b.0
> ...

Hi Tom,

thanks for the test results. I guess they were what you expected.
They do seem to point to something in the hot-unplug code that
Windows doesn't like. I'm a little confused by this thread,
do you get the same result with your force devfn change?

I'll try and get a test environment with Windows set up for myself.  Sorry
if you have answered this before, but which version of Windows are you
using and is it 32 or 64bit?

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.