[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Possible bug with pass-through hot-plug?

  • To: Simon Horman <horms@xxxxxxxxxxxx>
  • From: Tom Rotenberg <tom.rotenberg@xxxxxxxxx>
  • Date: Sun, 11 Oct 2009 11:57:00 +0200
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Sun, 11 Oct 2009 02:57:23 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=ui/vBkwUIz+hJ7Yd8GQ07viBmwSbwHbJLTT1PiYlnaK5ICmzE4jez9v7mPPEzIkR// Hky3NJ+GBAvpzm9ufd0I9+5wslvesfSjeggtDmYgJqk+wTU4tGZELhL4GkjrRGzoRrUj d3j2zZB71YSxmZ60IjdVcGWG4j7/K56bPbRzw=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>


Well, just tried it, according to what u requested, and it still doesn't work.

Here are the lines from the qemu log:
platform_fixed_ioport: changed ro/rw state of ROM memory area. now is rw state.
platform_fixed_ioport: changed ro/rw state of ROM memory area. now is ro state.
dm-command: hot insert pass-through pci dev
insert_to_pci_devfn: bdf_slt="0000:00:1b.0@e8"
insert_to_pci_devfn: devfn=0xe8 -> slot=0x1d, func=0x0
register_real_device: Assigning real physical device 00:1b.0 ...
pt_iomul_init: Error: pt_iomul_init can't open file
/dev/xen/pci_iomul: No such file or directory: 0x0:0x1b.0x0
pt_register_regions: IO region registered (size=0x00004000 base_addr=0xfc220004)
register_real_device: Real physical device 00:1b.0 registered successfuly!
IRQ type = INTx
generate a sci for PHP.
deassert due to disable GPE bit.
pt_pci_write_config: Warning: Guest attempt to set address to unused
Base Address Register. [00:1d.0][Offset:30h][Length:4]
dm-command: hot remove pass-through pci dev

I performed the following sequence:
xm create
<waited untill Windows booted>
xm pci-attach hvm 00:1b.0@1d
<I saw that it worked>
xm pci-detach hvm 00:1b.0


On Sat, Oct 10, 2009 at 3:41 AM, Simon Horman <horms@xxxxxxxxxxxx> wrote:
> Hi Tom,
> I will need to have someone locate some windows media for me,
> which won't be able to take place until at least Tuesday.
> Which version are you using? And is it 32 or 64 bit?
> In order to test my theory just apply the debug patch that
> I posted and look in the qemu logs as you did previously.
> But run the test using non-auto vslot and without your force-vslot patch.
> That is, something along the lines of:
>        xm pci-attach hvm 01:00.0@1d

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.