[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] dom0 crash with unstable

On 10/06/09 11:25, Bryan D. Payne wrote:
> (gdb) x/i 0xffffffff8100930a
> 0xffffffff8100930a <hypercall_page+778>:      add    %al,(%rax)
778/32 = hypercall 24 = vcpuop.  Probably idling.
> (gdb) x/i 0xffffffff811fea48
> 0xffffffff811fea48 <delay_tsc+62>:    
>     cmpq   $0x0,0x632538(%rip)        # 0xffffffff81830f88 <pv_cpu_ops+264>

That's almost certainly a kernel panic of some kind.  Working out where
it came from will be rather tedious: you need to look through the stack
dump to find code-ish looking addresses then x/i them (they'll be the
same basic format as 0xffffffff8xxxxxxx).

(I really need to work out why they tend not to get printed.)

>> What happens if you boot dom0 with fewer cpus?
> I tried adding "maxcpus=1" to the linux kernel line in grub.  I used
> this in conjunction with the "dom0_mem=2G" option for xen.  Dom0 still
> crashes the same as without the maxcpus option.
> Just for kicks, I tried a few other options...
> * setting mem=4G with dom0_mem=2G seemed still resulted in random dom0 
> crashing
> * setting noapic resulted in a consistent crash within Xen:
> (XEN) ----[ Xen-3.5-unstable  x86_64  debug=y  Not tainted ]----
> (XEN) CPU:    0
> (XEN) RIP:    e008:[<ffff82c48014fe29>] add_pin_to_irq+0x24/0xcc
> (XEN) RFLAGS: 0000000000010296   CONTEXT: hypervisor

That shouldn't happen.  Sounds like it might be fall-out from the recent
interrupt changes in Xen.  Did you supply "noapic" to Xen, dom0 or both?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.