[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] ask for the xen boot when panic on mount rootfs

  • To: "wang jeppeter" <jeppeter@xxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
  • Date: Wed, 30 May 2007 16:30:43 +0200
  • Delivery-date: Wed, 30 May 2007 07:36:14 -0700
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>
  • Thread-index: AceixEHpy2tVbR1hSOWC0zhIa1mm0QAAoSqQ
  • Thread-topic: [Xen-devel] ask for the xen boot when panic on mount rootfs


> -----Original Message-----
> From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx 
> [mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of 
> wang jeppeter
> Sent: 30 May 2007 15:10
> To: xen-devel@xxxxxxxxxxxxxxxxxxx
> Subject: [Xen-devel] ask for the xen boot when panic on mount rootfs
> Everyone:
>      hello , i have a question when i boot from the xen built 
> on 3.0.4 source code which made i stumble on mounting rootfs 
> , i get it panic when it can not open rootfs . my disk is 
> sata disk of WD 250G ,and i built all the source code in 
> ubuntu feisty amd-64 platform on gcc-3.4.1 compiler . First 
> time i doubt whether i am not compile the ext3 file system in 
> the xen kernel (my rootfs is ext3 file system),but when i 
> rebuilt it with assuring of the ext3 fs in the xen kernel , i 
> met the same error,  the grub menu.lst  is like this
> title xen opt 
> root   (hd0,5)
> kernel  /xen-2.16.gz
> module  /vmlinuz-2.6.16-xen ro root=/dev/sda3 console=tty0

Unless your build of Xen Linux is different from the "standard build",
you'll probably need an "initrd" for the modules needed to read your
root filesystem and disk drivers for the /dev/sda3. 

This means you boot into your standard distribution (e.g. ubuntu) and
run something like "mkinitrd /boot/initrd-2.6.16-xen 2.6.16-xen", and
add a "module /initrd-2.6.16-xen" to your menu.lst file. 

> because my root fs is /dev/sda3 and i mount   /dev/sda6 for 
> /boot directory 
> root (hd0,5) is just copied from the right one of ubuntu 
> original kernel.
> when i switched to the ubuntu  xen package on command 
> "apt-get install xenman ",it also failed on the same error 
> ,can not open sda3 for rootfs.
> would someone help me ,which the problem it is .
> thank you very much .
> regards.
> jeppeter

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.