[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] ask for the xen boot when panic on mount rootfs

  • To: xen-devel@xxxxxxxxxxxxxxxxxxx
  • From: "wang jeppeter" <jeppeter@xxxxxxxxx>
  • Date: Wed, 30 May 2007 22:09:45 +0800
  • Delivery-date: Wed, 30 May 2007 07:07:58 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type; b=f48kykeRMm0ivfcw3TFEih24cQfgQXU5XOHZGD0Li65+fGf00/KZ2oAarrWQj2FY151UxqiF1xnEDhM34jZle6dDJkcmONowkNSTtQ8R/je7e+NubIfEEJZPVR7dcjpBCjBklj7fvb50fGVmzx02p3+0NvleREaebbOq2bwPXe4=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

     hello , i have a question when i boot from the xen built on 3.0.4 source code which made i stumble on mounting rootfs , i get it panic when it can not open rootfs . my disk is sata disk of WD 250G ,and i built all the source code in ubuntu feisty amd-64 platform on gcc-3.4.1 compiler . First time i doubt whether i am not compile the ext3 file system in the xen kernel (my rootfs is ext3 file system),but when i rebuilt it with assuring of the ext3 fs in the xen kernel , i met the same error,  the grub menu.lst  is like this
title xen opt 
root   (hd0,5)
kernel  /xen-2.16.gz
module  /vmlinuz-2.6.16-xen ro root=/dev/sda3 console=tty0
because my root fs is /dev/sda3 and i mount   /dev/sda6 for /boot directory 
root (hd0,5) is just copied from the right one of ubuntu original kernel.
when i switched to the ubuntu  xen package on command "apt-get install xenman ",it also failed on the same error ,can not open sda3 for rootfs.
would someone help me ,which the problem it is .
thank you very much .
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.