[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] vblade in Xen 3

Hi All,

Has anyone got vblade (server daemon for ATA over Ethernet) working
reliably in a Xen 3 dom0 yet?  There was a thread (excerpt below) last
July about doing this in Xen 2, so I know this worked at some point...

I have it built under xen 3/linux 2.6.12, and mostly running, but the
client aoe module hangs after a few seconds under load (bonnie or dd
of a few hundred MB in an ext3 filesystem, physical is /dev/sdb).  An
strace on the vblade process tends to show it waiting on read() from
the raw ethernet socket; aoeping works fine, aoe-stat from the hung
client shows the device 'up'. but aoe-stat from another client shows
the device 'down,paused'.

I've tried this when binding vblade to eth0.  If I take a hint from
the message below and bind to xenbr0 instead, then the aoe client
can't see the vblade device at all, according to aoe-stat; this is the
reverse of the symptoms which Jeb noticed back then.  If I try to
bypass the internal bridge and bind vblade directly to peth0, then the
client still can't see it.  Still troubleshooting this.

Does anyone recognize this symptom already, or have any hints for
what to look at?

BTW, things work great if I run the vblade server on a vanilla 2.6.11
kernel -- I've had bonnie running in a loop for the last 10 hours on a
Xen 3 dom0 aoe client, talking to a vanilla server; performance over a
100Mb link is better than half of local SCSI disk speeds; I can't wait
to get some GigE cards...



On Mon, Jul 25, 2005 at 05:28:52PM +0100, Mark Williamson wrote:
> > You nailed it!  To export from dom0 (to real network -- not tested with
> > domU hosts) you have to tell vblade to bind to xen-br0 (on xen2 -- not
> > tested with xen3) not eth0.  I never would have thought to do this as
> > dom0 should be as close to "real" linux as possible.
> The bridging code is the standard Linux bridge: I'd expect this to happen on 
> native Linux too, when using bridging.
> Cheers,
> Mark
> From: Jeb Campbell <jebc@xxxxxxxxxxxxxxx>
> > So in summary for aoe on xen:
> >
> > 1. Compile aoe in kernel (Device Drivers/Block devices/ATA over
> > Ethernet) to be able to see aoe devices (remember you can't see vblade
> > exports on the host exporting them).  Module did not work for me, but
> > your milage may vary ;) .
> >
> > 2. If you want to use vblade (http://aoetools.sf.net) to export a
> > disk/lvm/loopback device, you have to use xen-br0 (for xen2 -- adjust
> > for xen3) NOT eth0.
> >
> > Thanks for the help on the list.
> >
> > PS - I'm getting in the 3U SATA raid from coraid in a week or 2, and
> > assuming I can get xen3 on my single proccessor Sun V20z (Opteron), I
> > will post performance numbers from dom0 and domU.  As the sata boxes do
> > raid on board, it should be a great option for large and/or redundant
> > shared drives for xen migration.
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Stephen G. Traugott  (KG6HDQ)
UNIX/Linux Infrastructure Architect, TerraLuna LLC
http://www.stevegt.com -- http://Infrastructures.Org

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.